Bug 602735 - e-utils warning about illegal pop-up window call
e-utils warning about illegal pop-up window call
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-10 11:26 EDT by Matthew Saltzman
Modified: 2010-06-14 12:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-14 12:42:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 603468 None None None Never

  None (edit)
Description Matthew Saltzman 2010-06-10 11:26:52 EDT
Description of problem:

I crashed evo by sending a message.  The evo window vanished.  Issued 'evolution --force-shutdown' to clean up before restarting.  The message had apparently been placed in the outbox but not sent yet, as the pop-up displayed asking for confirmation: "You have unsent messages, do you wish to quit anyway?"
On the console, I got the following warning.

(evolution:4835): e-utils-WARNING **: Something called e_alert_dialog_constructed() with a NULL parent window.  This is no longer legal, please fix it.


Version-Release number of selected component (if applicable):
evolution-2.30.1-8.fc13.x86_64

How reproducible:
Always (in the sense that when I get the crash while sending, the pop-up and warning show up reliably).  Intermittently (in the sense that the crash is intermittent.

Steps to Reproduce:
1. Send a message.
2. Crash (maybe).  Might only happen sending from Exchange--that's what I was doing.
3. Issue evolution --force-shutdown'
  
Actual results:
As above.

Expected results:
No warning.

Additional info:
Comment 1 Milan Crha 2010-06-11 03:34:09 EDT
Thanks for a bug report. I guess the warning is sort of bogus here, because you shouldn't be asked for "quitting evolution" when issuing --force-shutdown, also because the dialog is using the main window, which apparently doesn't exists. I would use an upstream bug [1] for the issue.

Do you have a crasher bug filled too, please? And if so, could you give me its bug number, to check the trace where the crash happened? Thanks in advance.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=603468
Comment 2 Matthew Saltzman 2010-06-11 11:42:39 EDT
That would be Bug #602728.
Comment 3 Milan Crha 2010-06-14 12:42:14 EDT
(In reply to comment #2)
> That would be Bug #602728.    

Thanks. I'm closing this bug report due to the upstream equivalent. See the upstream bug for any further updates.

Note You need to log in before you can comment on or make changes to this bug.