Bug 60275 - Module install scripts are incorrect
Module install scripts are incorrect
Status: CLOSED DUPLICATE of bug 60037
Product: Red Hat Raw Hide
Classification: Retired
Component: php (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-02-23 15:22 EST by andrew.simpson
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-03-01 00:27:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description andrew.simpson 2002-02-23 15:22:13 EST
Description of Problem:
Modules won't work with Apache, because they are not loaded automatically.

Version-Release number of selected component (if applicable):
php 4.1.1-4

How Reproducible:
Everytime installed

Steps to Reproduce:
1. Install the rpm modules php-mysql, php-ldap etc.

Actual Results:
Modules don't work with Apache

Expected Results:
The opposite to the above!

Additional Information:
The rpm contains a script to add the module into php.ini.  However the search
string does not occur in the php.ini file, so the script does nothing.
Comment 1 Techwolf 2002-02-28 13:58:32 EST
The script needs to do this also to php.ini.

extension_dir = ./
extension_dir = /usr/lib/php4
so that php can find the modules. In my case, mysql.
Comment 2 andrew.simpson 2002-03-01 00:27:41 EST
The last comment:

>The script needs to do this also to php.ini. change
>extension_dir = ./
>extension_dir = /usr/lib/php4
>so that php can find the modules. In my case, mysql.

I've actually entered as bug number 600037
Comment 3 Phil Copeland 2002-03-04 15:50:25 EST

*** This bug has been marked as a duplicate of 60037 ***
Comment 4 andrew.simpson 2002-03-05 01:46:54 EST
Whoops.  Not quite closed!!

The comment made by techwolf@att.net is a duplicate of 60037.  But my original 
comment is not.

The perl scripts in the postinstall script do not correct the windows
pathnames for the modules because the search strings are wrong.

For instance in the spec file:

%post mysql
	%{__perl} -pi -e "s|^;extension=mysql.so|extension=mysql.so|" %{_sysconfdir}/php.ini
	%{__perl} -pi -e "s|^;extension=mysql.dll|extension=mysql.so|" %{_sysconfdir}/php.ini

Should be:

%post mysql
	%{__perl} -pi -e "s|^;extension=mysql.so|extension=mysql.so|" %{_sysconfdir}/php.ini
	%{__perl} -pi -e "s|^;extension=php_mysql.dll|extension=mysql.so|" %{_sysconfdir}/php.ini

Comment 5 Phil Copeland 2002-03-05 03:54:54 EST
Bugger. There's always something that I mistype...
Fixed for next rawhide

Note You need to log in before you can comment on or make changes to this bug.