Bug 602780 - X display lockups with kde/nouveau
Summary: X display lockups with kde/nouveau
Status: CLOSED DUPLICATE of bug 596330
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
low
high
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-10 18:24 UTC by Neil Katin
Modified: 2010-06-29 18:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 18:36:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (31.20 KB, application/x-trash)
2010-06-10 18:24 UTC, Neil Katin
no flags Details
dmesg output (45.51 KB, text/plain)
2010-06-10 18:24 UTC, Neil Katin
no flags Details
xorg.conf (856 bytes, text/plain)
2010-06-10 18:25 UTC, Neil Katin
no flags Details

Description Neil Katin 2010-06-10 18:24:13 UTC
Created attachment 423003 [details]
Xorg.0.log

Description of problem:

I recently upgraded to fedora13.  Ever since then X locks up every few
hours.

This is displayed in the Xorg.0.log file:

[176146.816] [mi] EQ overflowing. The server is probably stuck in an infinite loop.
[176146.874]
Backtrace:
[176146.982] 0: /usr/bin/X (xorg_backtrace+0x28) [0x49e708]
[176146.996] 1: /usr/bin/X (mieqEnqueue+0x1f4) [0x49e0b4]
[176146.996] 2: /usr/bin/X (xf86PostMotionEventP+0xc4) [0x477e24]
[176146.997] 3: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7f7918b32000+0x3dbf) [0x7f7918b35dbf]
[176146.997] 4: /usr/bin/X (0x400000+0x6aae7) [0x46aae7]
[176146.997] 5: /usr/bin/X (0x400000+0x117b43) [0x517b43]
[176146.997] 6: /lib64/libc.so.6 (0x32a1600000+0x32a40) [0x32a1632a40]
[176146.998] 7: /usr/lib64/xorg/modules/drivers/nouveau_drv.so (0x7f791a491000+0x1f458) [0x7f791a4b0458]
[176146.998] 8: /usr/lib64/xorg/modules/drivers/nouveau_drv.so (0x7f791a491000+0x2093d) [0x7f791a4b193d]
[176146.998] 9: /usr/lib64/libdrm_nouveau.so.1 (nouveau_pushbuf_flush+0x1a2) [0x7f791a28e462]
[176146.998] 10: /usr/lib64/xorg/modules/libexa.so (0x7f7919c2c000+0x90f1) [0x7f7919c350f1]
[176146.998] 11: /usr/lib64/xorg/modules/libexa.so (0x7f7919c2c000+0x93ad) [0x7f7919c353ad]
[176146.998] 12: /usr/bin/X (miCopyRegion+0x28d) [0x5478fd]
[176146.998] 13: /usr/bin/X (miDoCopy+0x44a) [0x547e0a]
[176146.998] 14: /usr/lib64/xorg/modules/libexa.so (0x7f7919c2c000+0x8697) [0x7f7919c34697]
[176146.998] 15: /usr/bin/X (0x400000+0xd4478) [0x4d4478]
[176146.999] 16: /usr/bin/X (0x400000+0x2ae7c) [0x42ae7c]
[176146.999] 17: /usr/bin/X (0x400000+0x2c32c) [0x42c32c]
[176146.999] 18: /usr/bin/X (0x400000+0x219ca) [0x4219ca]
[176146.999] 19: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x32a161ec5d]
[176146.999] 20: /usr/bin/X (0x400000+0x21579) [0x421579]

The machine OK (one can log in with ssh), but X is unresponsive.
Killing X and restarting instantly prints the infinite loop
message, so the problem seems to be at the hardware level.

Version-Release number of selected component (if applicable):

xorg-x11-drv-nouveau.x86_64                    1:0.0.16-6.20100423git13c1043.fc13
xorg-x11-drivers.x86_64                        7.3-14.fc13                                 @anaconda-InstallationRepo-201005130101.x86_64   

from lspci:
01:00.0 VGA compatible controller: nVidia Corporation G86 [GeForce 8400M GS] (rev a1)


How reproducible:

I don't have a good reproducible test case, it seems to happen at "random" times.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Neil Katin 2010-06-10 18:24:46 UTC
Created attachment 423005 [details]
dmesg output

Comment 2 Neil Katin 2010-06-10 18:25:10 UTC
Created attachment 423007 [details]
xorg.conf

Comment 3 Neil Katin 2010-06-29 18:36:49 UTC

*** This bug has been marked as a duplicate of bug 596330 ***


Note You need to log in before you can comment on or make changes to this bug.