Bug 602814 - SELinux is preventing /usr/libexec/gconf-defaults-mechanism "search" access on mgalgoci.
SELinux is preventing /usr/libexec/gconf-defaults-mechanism "search" access ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:87e5d4d8864...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-10 15:54 EDT by Matthew Galgoci
Modified: 2010-08-15 08:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-11 01:34:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Galgoci 2010-06-10 15:54:06 EDT
Summary:

SELinux is preventing /usr/libexec/gconf-defaults-mechanism "search" access on
mgalgoci.

Detailed Description:

SELinux denied access requested by gconf-defaults-. It is not expected that this
access is required by gconf-defaults- and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:gconfdefaultsm_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                mgalgoci [ dir ]
Source                        gconf-defaults-
Source Path                   /usr/libexec/gconf-defaults-mechanism
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           GConf2-2.28.1-1.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-23.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.5-112.fc13.i686.PAE #1
                              SMP Thu May 27 02:56:20 UTC 2010 i686 i686
Alert Count                   2
First Seen                    Thu 10 Jun 2010 05:41:33 AM EDT
Last Seen                     Thu 10 Jun 2010 05:41:33 AM EDT
Local ID                      7d88d534-1ee2-4ec0-8384-f83bc47c86e1
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1276162893.532:20766): avc:  denied  { search } for  pid=2272 comm="gconf-defaults-" name="mgalgoci" dev=dm-3 ino=1572865 scontext=system_u:system_r:gconfdefaultsm_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1276162893.532:20766): arch=40000003 syscall=39 success=no exit=-13 a0=89ed0d8 a1=1c0 a2=c5e23c a3=0 items=0 ppid=1 pid=2272 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="gconf-defaults-" exe="/usr/libexec/gconf-defaults-mechanism" subj=system_u:system_r:gconfdefaultsm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gconf-defaults-,gconfdefaultsm_t,user_home_t,dir,search
audit2allow suggests:

#============= gconfdefaultsm_t ==============
allow gconfdefaultsm_t user_home_t:dir search;
Comment 1 Miroslav Grepl 2010-06-11 01:34:49 EDT
It looks like you have mislabeled your home directory. Try to execute

restorecon -R -v /home

Should fix. Please reopen if the problem still persists.

Note You need to log in before you can comment on or make changes to this bug.