Bug 60282 - man-1.5j-2 / gzip-1.3.2-2 produce lots of "zcat: stdout: Broken pipe" warnings
man-1.5j-2 / gzip-1.3.2-2 produce lots of "zcat: stdout: Broken pipe" warnings
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-24 07:39 EST by Jonathan Kamens
Modified: 2016-11-24 10:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-26 11:02:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-02-24 07:39:15 EST
I get a whole bunch of these when I run makewhatis with man-1.5j-2 and
gzip-1.3.2-2 installed:

zcat: stdout: Broken pipe
Comment 1 Bernhard Rosenkraenzer 2002-02-26 07:56:56 EST
Hmm... 
 
[root@spock root]# rpm -q man gzip 
man-1.5j-2 
gzip-1.3.2-2 
[root@spock root]# makewhatis 
zcat: ./cancel.1.gz: No such file or directory 
zcat: ./cancel-cups.1.gz: No such file or directory 
[root@spock root]# 
 
Looks OK here, can you figure out what man pages it's barfing on for you?
Comment 2 Bill Nottingham 2002-02-26 10:58:59 EST
Do you have the rawhide man-pages-ko package installed?
Comment 3 Jonathan Kamens 2002-02-26 11:02:03 EST
I can't duplicate the problem anymore.  I suspect it was caused by a bug in
glibc-2.2.90-6.  I'm not going to close this bug because I'm not sure of what
resolution to assign it (or whether it should perhaps be moved into the glibc
module before being closed).
Comment 4 Bernhard Rosenkraenzer 2002-02-26 11:04:34 EST
Yes, I can reproduce it with an older glibc. It's another effect of the mmaped stdio bug. 

Note You need to log in before you can comment on or make changes to this bug.