Bug 602839 - [abrt] crash in elfutils-0.147-1.fc13: elf_machine_rel_relative: Process /usr/bin/eu-unstrip was killed by signal 11 (SIGSEGV)
[abrt] crash in elfutils-0.147-1.fc13: elf_machine_rel_relative: Process /usr...
Status: CLOSED DUPLICATE of bug 574245
Product: Fedora
Classification: Fedora
Component: elfutils (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
abrt_hash:9c9f403d2916d3439f55ece7bdc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-10 16:52 EDT by Matthieu Araman
Modified: 2010-06-14 07:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-14 07:15:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (92.00 KB, text/plain)
2010-06-10 16:52 EDT, Matthieu Araman
no flags Details

  None (edit)
Description Matthieu Araman 2010-06-10 16:52:47 EDT
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: eu-unstrip --core=/var/cache/abrt/ccpp-1276188427-5280/coredump -n
comment: may be related to bug 574245
component: elfutils
crash_function: elf_machine_rel_relative
executable: /usr/bin/eu-unstrip
global_uuid: 9c9f403d2916d3439f55ece7bdc1f686cb7c9b14
kernel: 2.6.33.5-112.fc13.i686
package: elfutils-0.147-1.fc13
rating: 4
reason: Process /usr/bin/eu-unstrip was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1.may be related to bug 574245 (suspend bug)
2.
3.
Comment 1 Matthieu Araman 2010-06-10 16:52:49 EDT
Created attachment 423049 [details]
File: backtrace
Comment 2 Roland McGrath 2010-06-13 21:12:28 EDT
If you still have the file /var/cache/abrt/ccpp-1276188427-5280/coredump please try to reproduce the failure by running " eu-unstrip --core=/var/cache/abrt/ccpp-1276188427-5280/coredump -n" by hand.  If that does crash, then please attach that coredump file if you can (or make it available to the elfutils maintainers in some other fashion, if it's very large).

The backtrace is quite suspicious and may indicate something like random memory clobberation rather than the kind of bug it appears to be.  If you can't reproduce the crash running eu-unstrip by hand, or you no longer have that file, then I think we'll have to chalk this up to randomness and close the bug.
Comment 3 Michal Schmidt 2010-06-14 07:15:50 EDT
(In reply to comment #0)
> 1.may be related to bug 574245 (suspend bug)

(In reply to comment #2)
> The backtrace is quite suspicious and may indicate something like random
> memory clobberation rather than the kind of bug it appears to be.

Yes, this is most likely caused by the kernel bug related to hibernation. Closing as a duplicate of the kernel bug.

*** This bug has been marked as a duplicate of bug 574245 ***

Note You need to log in before you can comment on or make changes to this bug.