Bug 60285 - makewhatis "ignored strange file names" errors should not go to /dev/tty
Summary: makewhatis "ignored strange file names" errors should not go to /dev/tty
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: man   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: wdovlrrw
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-24 12:53 UTC by Jonathan Kamens
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-24 13:38:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2002-02-24 12:53:14 UTC
I ran makewhatis with both stdout and stderr redirected to a file, and yet I got
a bunch of "ignored strange file name" errors in my xterm window.  This is
because the gawk script explicitly sends these errors to /dev/tty, which is just
broken.  It should use /dev/stderr.

Comment 1 Jonathan Kamens 2002-02-24 13:38:20 UTC
I should also mention that the redirect to /dev/tty breaks when makewhatis is
run out of /etc/cron.daily/makewhatis.cron:

awk: cmd. line:54: (FILENAME=- FNR=548) fatal: can't redirect to `/dev/tty' (No
such device or address)


Comment 2 Bernhard Rosenkraenzer 2002-02-25 13:20:31 UTC
You're right, fixed in 1.5j-3


Note You need to log in before you can comment on or make changes to this bug.