Bug 602861 - Make the chirp_client library and header available
Summary: Make the chirp_client library and header available
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: condor (Show other bugs)
(Show other bugs)
Version: 14
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Matthew Farrellee
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-10 21:41 UTC by Mattias Ellert
Modified: 2010-08-02 20:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-02 20:25:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that builds shared chirp client library. (760 bytes, patch)
2010-06-29 14:08 UTC, Mattias Ellert
no flags Details | Diff

Description Mattias Ellert 2010-06-10 21:41:58 UTC
Description of problem:
libchirp_client.so and chirp_client.h are not installed.

It is possible to build root (review bug #542990) with chirp support. But in order to do this the header file and library must be available.

Currently the Fedora condor build creates a private static library which is not packaged. Could the build be changed to create a shared library instead that can be installed on Fedora?

Version-Release number of selected component (if applicable):
condor-7.4.2-1.fc13.i686.rpm

Comment 1 Matthew Farrellee 2010-06-28 21:18:03 UTC
The Condor build system is only setup to build libchirp_client.a. If you have suggestions (patch?) on how to build a properly versioned libchirp_client.so, I'd be happy to entertain it. The best means to get such a change done is by contributing directly upstream:

   https://condor-wiki.cs.wisc.edu/index.cgi/wiki?p=MakingContributions

Comment 2 Mattias Ellert 2010-06-29 14:08:17 UTC
Created attachment 427694 [details]
Patch that builds shared chirp client library.

The changes to the Imakefile needed to create a shared library instead of a static one is quite minor - patch is attached.

The shared library created with these changes is called libchirp_client.so and has no soname. It is possible to modify the rules so that a soname is added, if you have any idea what it is supposed to be?

Comment 3 Bug Zapper 2010-07-30 12:05:25 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Matthew Farrellee 2010-08-02 20:25:07 UTC
Mattias,

Let's take this to http://condor-wiki.cs.wisc.edu so the solution can be discussed in the Condor community and properly sent upstream.

We'll likely have to properly version the so, and provide upstream with a method of making sure they keep it updated. Hopefully simple since chirp_client.h has not changed in 5 years.

Also, there is work to move building Condor from imake to cmake, and the people doing that work will need to know about this and incorporate it.


Note You need to log in before you can comment on or make changes to this bug.