Bug 602893 - need to ship a module for gtk3 as well as gtk2
Summary: need to ship a module for gtk3 as well as gtk2
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Peng Huang
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-10 23:45 UTC by Matthias Clasen
Modified: 2011-04-12 01:56 UTC (History)
3 users (show)

Fixed In Version: ibus-1.3.5-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-27 23:33:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthias Clasen 2010-06-10 23:45:46 UTC
The next version of gnome is going to start the transition to gtk3. I don't expect it to be fully completed by F14, but there will certainly be applications which use gtk3 instead of gtk2.

Since gtk2 and gtk3 are parallel installable, gtk3 needs its modules to be linked against gtk3 and installed in $libdir/gtk-3.0/3.0.0/immodules instead of $libdir/gtk-2.0/2.10.0/immodules. The code itself does not need to be changed (provided you do not use deprecated apis or direct access to struct members).

Comment 1 Peng Huang 2010-06-11 00:20:21 UTC
I have added gtk3 support in upstream. I will build it for fedora soon.

Comment 2 Peng Huang 2010-06-12 02:03:24 UTC
Fixed in ibus-1.3.5-1.fc14


Note You need to log in before you can comment on or make changes to this bug.