Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 602934 - [abrt] crash in fldigi-3.20.12-2.fc13: Process /usr/bin/fldigi was killed by signal 11 (SIGSEGV)
[abrt] crash in fldigi-3.20.12-2.fc13: Process /usr/bin/fldigi was killed by ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fldigi (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Randall "Randy" Berry
Fedora Extras Quality Assurance
abrt_hash:38267490789e048918879a8df31...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-11 00:04 EDT by Jeff Sumner
Modified: 2010-06-19 23:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-19 23:28:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (31.18 KB, text/plain)
2010-06-11 00:04 EDT, Jeff Sumner
no flags Details

  None (edit)
Description Jeff Sumner 2010-06-11 00:04:50 EDT
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: fldigi
comment: I'm trying to debug why FLDIGI will bring X down, so started it with redirection enabled. CTRL-C and it cored.
component: fldigi
executable: /usr/bin/fldigi
global_uuid: 38267490789e048918879a8df310cd1aad2d6496
kernel: 2.6.33.5-112.fc13.i686
package: fldigi-3.20.12-2.fc13
rating: 3
reason: Process /usr/bin/fldigi was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Start FLDIGI with output redirected via 2>&1 for debugging
2. Press CTRL-C to quit
3. Watch the core.
Comment 1 Jeff Sumner 2010-06-11 00:04:52 EDT
Created attachment 423131 [details]
File: backtrace
Comment 2 Randall "Randy" Berry 2010-06-11 01:31:56 EDT
Hi Jeff,
I submitted your report upstream as I was unable to reproduce the bug here. Could you please include the rig you are using with fldigi if you are using CAT control? And if you are using pulseaudio or portaudio. 

As many details that you can provide may help allot.

Meanwhile Fldigi 3.20-15 will be submitted to updates-testing shortly. I am test building it as of this report. 

Thanks es 73 de Randy N3LRX
Comment 3 Jeff Sumner 2010-06-11 07:51:24 EDT
Thank you Randy!
Rig control is for a Ten-Tec Orion, and I'm using the Portaudio, but it's setting Pulseaudio as the engine to use.
I'm actually having a lot of trouble with this particular build of Fedora 13 with regards to X- I'm troubleshooting why resizing FLDIGI crashes X. I'm also troubleshooting why X is missing mouse-up events (where "mouse-down" becomes sticky and won't release until some random several seconds of moving it via the track-pad/point stick, and randomly pressing right/left mouse buttons) where I decided to run FLDIGI in this way.

This crash happened whilst FLDIGI was doing normal decoding (PSK31, I believe) and BEFORE the configuration file was saved for the first time.
Comment 4 Randall "Randy" Berry 2010-06-19 16:12:06 EDT
3.20.15 has been pushed to updates-testing please see if the problem still occurs.
Comment 5 Jeff Sumner 2010-06-19 22:47:57 EDT
That fixed it- thanks!

Note You need to log in before you can comment on or make changes to this bug.