Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 602938 - am-utils fails on f13 with amfs_toplvl_mount
am-utils fails on f13 with amfs_toplvl_mount
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: am-utils (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-11 00:38 EDT by Douglas Needham
Modified: 2010-10-27 18:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: am-utils-6.1.5-16.1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-15 08:41:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Main amd.conf file (785 bytes, application/octet-stream)
2010-06-11 00:38 EDT, Douglas Needham
no flags Details
amd.home map file (205 bytes, text/plain)
2010-06-11 00:39 EDT, Douglas Needham
no flags Details
Messages from amd in /var/log/messages on machine which works (8.24 KB, text/plain)
2010-06-11 00:40 EDT, Douglas Needham
no flags Details
Messages from amd in /var/log/messages on machine which exhibits problem (f13) (4.09 KB, text/plain)
2010-06-11 00:42 EDT, Douglas Needham
no flags Details

  None (edit)
Description Douglas Needham 2010-06-11 00:38:53 EDT
Created attachment 423134 [details]
Main amd.conf file

Description of problem:
am-utils is once again having problems dealing with mountpoints.  With the same exact configuration files, mounts which are either nfs or loopback work under f12, but under f13 (and a nearly identical set of packages installed thanks to cobbler and a kickstart file), the top level mounts fail with messages such as

    '/home': mount: No locks available
    amfs_toplvl_mount: amfs_mount failed: No locks available

The only mount which works is /net

Version-Release number of selected component (if applicable):
    6.1.5 (build 1)

How reproducible:
Always

Steps to Reproduce:
1. Install f13 system with am-utils.  Home directories for users are either
   via NFS or in /homes and accessed through /home.
2. Attempt to access directory though /home/user
  
Actual results:
    root@resune# cd cinnion
    -bash: cd: /home/cinnion: No such file or directory

Expected results:
Directory is mounted/linked as configured and accessable.

Additional info:
Attempts at the old workaround fail.
Comment 1 Douglas Needham 2010-06-11 00:39:56 EDT
Created attachment 423135 [details]
amd.home map file
Comment 2 Douglas Needham 2010-06-11 00:40:54 EDT
Created attachment 423136 [details]
Messages from amd in /var/log/messages on machine which works
Comment 3 Douglas Needham 2010-06-11 00:42:03 EDT
Created attachment 423137 [details]
Messages from amd in /var/log/messages on machine which exhibits problem (f13)
Comment 4 Douglas Needham 2010-06-11 00:43:53 EDT
This bug all but renders the f13 systems non-workable, as the only option left is to use nfs mounts in /etc/fstab.
Comment 5 jeff 2010-06-21 13:16:15 EDT
(In reply to comment #0)

>     '/home': mount: No locks available
>     amfs_toplvl_mount: amfs_mount failed: No locks available
> 

It appears the patch to fix the nolocks/toplvl problem is already in
the am-utils package.  The issue seems to be that during the build,
one of the configure test scripts fails and that leads to the toplvl
patch not being compiled in.

At compile-time, the configure script tests to see if
<linux/nfs_mount.h> exists.  <linux/nfs_mount.h> includes <linux/in.h>.
The problem is that <linux/in.h> needs <sys/socket.h> to have
already been loaded...without it something is undefined and the
compiler returns an error.  Once the error occurs, the configure 
script concludes that <linux/nfs_mount.h> does not exist.  The
toplvl patch depends on some definitions in <linux/nfs_mount.h>.

I used the following patch to include <sys/socket.h> in the configure
test script and rebuild.

diff -uNr am-utils-6.1.5/configure.in am-utils-6.1.5-new/configure.in
--- am-utils-6.1.5/configure.in	2006-05-11 10:25:47.000000000 -0700
+++ am-utils-6.1.5-new/configure.in	2010-06-17 20:01:48.000000000 -0700
@@ -620,6 +620,9 @@
 # ifndef __KERNEL__
 #  define __KERNEL__
 # endif /* __KERNEL__ */
+#ifdef HAVE_SYS_SOCKET_H
+# include <sys/socket.h>
+#endif /* HAVE_SYS_SOCKET_H */
 #ifdef HAVE_LINUX_SOCKET_H
 # include <linux/socket.h>
 #endif /* HAVE_LINUX_SOCKET_H */
Comment 6 Martin Simmons 2010-09-03 06:33:15 EDT
I had this problem too, so thanks for posting the patch.

After adding it to the end of am-utils-6.1.5-nolock-toplvl.patch and rebuilding, amd works again with my maps.
Comment 7 Fedora Update System 2010-10-06 06:09:00 EDT
am-utils-6.1.5-16.1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/am-utils-6.1.5-16.1.fc13
Comment 8 Fedora Update System 2010-10-06 06:32:34 EDT
am-utils-6.1.5-17.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/am-utils-6.1.5-17.fc14
Comment 9 Fedora Update System 2010-10-07 15:51:31 EDT
am-utils-6.1.5-17.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update am-utils'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/am-utils-6.1.5-17.fc14
Comment 10 Fedora Update System 2010-10-15 08:41:42 EDT
am-utils-6.1.5-17.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2010-10-27 18:35:16 EDT
am-utils-6.1.5-16.1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.