Bug 60297 - java plugin is not detected with mozilla-0.9.8-2.i386
java plugin is not detected with mozilla-0.9.8-2.i386
Product: Red Hat Raw Hide
Classification: Retired
Component: mozilla (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2002-02-24 18:33 EST by Stuart Fairley
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-25 03:42:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Stuart Fairley 2002-02-24 18:33:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020205

Description of problem:
Despite java being properly available (soft link in the plugins directory), it
was not detected by 0.9.8-2

Using 0.9.8 directly from mozilla.org worked however.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install mozilla 0.9.8-2
2. Go to java web-site and let the java plugin install automatically
3. Restart mozilla

Actual Results:  Java is not available - when going to a site requiring java it
goes through the install procedure again (and again, etc).

Expected Results:  java should be available after first install

Additional info:

0.9.8 direct from mozilla works fine.
There is the soft link from the plugins directory to the java lib.
Java was installed from jre-1.3.1_02.i386.rpm and automatically from netscape
(both were 1.3.1 at least).

Calling /usr/lib/mozilla/mozilla-bin after manually setting up LD_LIBRARY_PATH
gave a message that the plugin failed to initialisation because of a missing
symbol - I have lost the record of which symbol it was, but it seemed to be
associated with the libxpcom.so library.
Comment 1 Bill Nottingham 2002-03-28 17:14:56 EST
Does this still happen with 0.9.9-x from rawhide?
Comment 2 Stuart Fairley 2002-04-14 16:28:52 EDT
I just tried 0.9.9-7 from rawhide, after manually making the link to java in the
plugins directory, all seems to work properly.

Note You need to log in before you can comment on or make changes to this bug.