Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 602975 - Matahari messages are not accepted by current version of qpid in F13
Matahari messages are not accepted by current version of qpid in F13
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: matahari (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Darryl L. Pierce
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-11 03:34 EDT by pmialon
Modified: 2015-06-21 20:07 EDT (History)
5 users (show)

See Also:
Fixed In Version: matahari-0.0.5-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 16:45:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
matahari fix for invalid shema (439 bytes, patch)
2010-06-11 03:34 EDT, pmialon
no flags Details | Diff

  None (edit)
Description pmialon 2010-06-11 03:34:41 EDT
Created attachment 423161 [details]
matahari fix for invalid shema

Description of problem:

When starting matahari, qpidd complain with :
warning Management Agent received invalid schema response: com.redhat.matahari.cpu

Version-Release number of selected component (if applicable):

0.0.4-7 of matahari
qpid-cpp-server-0.6.895736-4

How reproducible:


Steps to Reproduce:
1. launch matahari
2. watch the log of qpidd
3. qpid-tool report nothing from matahari
  
Actual results:

No messages are provided from matahari to qpidd

Additional info:

I fix this bug with the attached patch, without this patch at compilation time, compiler complain with  :
g++ -DHAVE_CONFIG_H -I. -I.. -I../src/qmf/com/redhat/matahari -DDBUS_API_SUBJECT_TO_CHANGE -I/usr/include/hal -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include     -fno-strict-aliasing   -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -c -o matahari-nic.o `test -f 'nic.cpp' || echo './'`nic.cpp
host.cpp: In member function 'void HostWrapper::reboot()':
host.cpp:223: warning: ignoring return value of 'int system(const char*)', declared with attribute warn_unused_result
host.cpp: In member function 'void HostWrapper::shutdown()':
host.cpp:228: warning: ignoring return value of 'int system(const char*)', declared with attribute warn_unused_result

It seems that the return of the function system need to be caught.
Comment 1 Darryl L. Pierce 2010-07-07 09:54:47 EDT
(In reply to comment #0)
> Created an attachment (id=423161) [details]
> matahari fix for invalid shema
> 
> Description of problem:
> 
> When starting matahari, qpidd complain with :
> warning Management Agent received invalid schema response:
> com.redhat.matahari.cpu
> 
> Version-Release number of selected component (if applicable):
> 
> 0.0.4-7 of matahari
> qpid-cpp-server-0.6.895736-4
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1. launch matahari
> 2. watch the log of qpidd
> 3. qpid-tool report nothing from matahari
> 
> Actual results:
> 
> No messages are provided from matahari to qpidd
> 
> Additional info:
> 
> I fix this bug with the attached patch, without this patch at compilation time,
> compiler complain with  :
> g++ -DHAVE_CONFIG_H -I. -I.. -I../src/qmf/com/redhat/matahari
> -DDBUS_API_SUBJECT_TO_CHANGE -I/usr/include/hal -I/usr/include/dbus-1.0
> -I/usr/lib64/dbus-1.0/include     -fno-strict-aliasing   -O2 -g -pipe -Wall
> -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
> --param=ssp-buffer-size=4 -m64 -mtune=generic -c -o matahari-nic.o `test -f
> 'nic.cpp' || echo './'`nic.cpp
> host.cpp: In member function 'void HostWrapper::reboot()':
> host.cpp:223: warning: ignoring return value of 'int system(const char*)',
> declared with attribute warn_unused_result
> host.cpp: In member function 'void HostWrapper::shutdown()':
> host.cpp:228: warning: ignoring return value of 'int system(const char*)',
> declared with attribute warn_unused_result
> 
> It seems that the return of the function system need to be caught.    

The patch is negligible: it's only a warning being issued that, in both cases, the return value's not being considered. The patch doesn't fix this problem, just removes the warning. ;)
Comment 2 Darryl L. Pierce 2010-07-07 10:55:17 EDT
I am unable to reproduce this issue on Fedora 13 with the following RPMs installed:

[mcpierce@mcpierce-laptop ~]$ rpm -qa *qpid*
qpid-cpp-client-devel-0.6.895736-4.fc13.x86_64
qpid-cpp-server-0.6.895736-4.fc13.x86_64
qpid-cpp-client-0.6.895736-4.fc13.x86_64
python-qpid-0.6.895736-1.fc13.noarch

Starting the qpidd daemon and then Matahari, I only see the following in /var/log/messages:

Jul  7 10:48:08 mcpierce-laptop qpidd[13019]: 2010-07-07 10:48:08 notice SASL disabled: No Authentication Performed
Jul  7 10:48:08 mcpierce-laptop qpidd[13019]: 2010-07-07 10:48:08 notice Listening on TCP port 5672
Jul  7 10:48:08 mcpierce-laptop qpidd[13019]: 2010-07-07 10:48:08 notice Broker running

Launching the qpid-tool and listing the available classes and agents, I see the proper list of each. I can peer at a single CPU agent on the host as well.

Can you recheck that the error still exists with the latest
Comment 3 pmialon 2010-07-07 12:43:27 EDT
(In reply to comment #2)
> I am unable to reproduce this issue on Fedora 13 with the following RPMs
> installed:
> 
> [mcpierce@mcpierce-laptop ~]$ rpm -qa *qpid*
> qpid-cpp-client-devel-0.6.895736-4.fc13.x86_64
> qpid-cpp-server-0.6.895736-4.fc13.x86_64
> qpid-cpp-client-0.6.895736-4.fc13.x86_64
> python-qpid-0.6.895736-1.fc13.noarch

chappy:~# rpm -qa \*qpid\*                                          18:39 #2367
qpid-cpp-server-devel-0.6.895736-4.fc13.x86_64
python-qpid-0.6.895736-1.fc13.noarch
qpid-cpp-client-0.6.895736-4.fc13.x86_64
qpid-cpp-client-devel-0.6.895736-4.fc13.x86_64
qpid-cpp-server-0.6.895736-4.fc13.x86_64


> Starting the qpidd daemon and then Matahari, I only see the following in
> /var/log/messages:
> 
> Jul  7 10:48:08 mcpierce-laptop qpidd[13019]: 2010-07-07 10:48:08 notice SASL
> disabled: No Authentication Performed
> Jul  7 10:48:08 mcpierce-laptop qpidd[13019]: 2010-07-07 10:48:08 notice
> Listening on TCP port 5672
> Jul  7 10:48:08 mcpierce-laptop qpidd[13019]: 2010-07-07 10:48:08 notice Broker
> running
> 
> Launching the qpid-tool and listing the available classes and agents, I see the
> proper list of each. I can peer at a single CPU agent on the host as well.
> 
> Can you recheck that the error still exists with the latest    

I just nothing for me, I don't see matahari only :

Management Object Types:
    ObjectType                           Active  Deleted
    ======================================================
    org.apache.qpid.broker:agent         1       0
    org.apache.qpid.broker:binding       8       0
    org.apache.qpid.broker:broker        1       0
    org.apache.qpid.broker:connection    2       0
    org.apache.qpid.broker:exchange      6       0
    org.apache.qpid.broker:queue         3       0
    org.apache.qpid.broker:session       2       0
    org.apache.qpid.broker:subscription  3       0
    org.apache.qpid.broker:system        1       0


(In reply to comment #1)
> (In reply to comment #0)
> > Created an attachment (id=423161) [details] [details]
> > matahari fix for invalid shema
> > 
> > Description of problem:
> > 
> > When starting matahari, qpidd complain with :
> > warning Management Agent received invalid schema response:
> > com.redhat.matahari.cpu
> > 
> > Version-Release number of selected component (if applicable):
> > 
> > 0.0.4-7 of matahari
> > qpid-cpp-server-0.6.895736-4
> > 
> > How reproducible:
> > 
> > 
> > Steps to Reproduce:
> > 1. launch matahari
> > 2. watch the log of qpidd
> > 3. qpid-tool report nothing from matahari
> > 
> > Actual results:
> > 
> > No messages are provided from matahari to qpidd
> > 
> > Additional info:
> > 
> > I fix this bug with the attached patch, without this patch at compilation time,
> > compiler complain with  :
> > g++ -DHAVE_CONFIG_H -I. -I.. -I../src/qmf/com/redhat/matahari
> > -DDBUS_API_SUBJECT_TO_CHANGE -I/usr/include/hal -I/usr/include/dbus-1.0
> > -I/usr/lib64/dbus-1.0/include     -fno-strict-aliasing   -O2 -g -pipe -Wall
> > -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
> > --param=ssp-buffer-size=4 -m64 -mtune=generic -c -o matahari-nic.o `test -f
> > 'nic.cpp' || echo './'`nic.cpp
> > host.cpp: In member function 'void HostWrapper::reboot()':
> > host.cpp:223: warning: ignoring return value of 'int system(const char*)',
> > declared with attribute warn_unused_result
> > host.cpp: In member function 'void HostWrapper::shutdown()':
> > host.cpp:228: warning: ignoring return value of 'int system(const char*)',
> > declared with attribute warn_unused_result
> > 
> > It seems that the return of the function system need to be caught.    
> 
> The patch is negligible: it's only a warning being issued that, in both cases,
> the return value's not being considered. The patch doesn't fix this problem,
> just removes the warning. ;)    

no in C++ a function that do nothing wich is the case without the return could be removed by the compiler so the stupid patch that I wrote, do something and work for us, and act as a constraint to fullfilled a correct qpid shema.
Comment 4 Fedora Update System 2010-07-07 13:31:41 EDT
matahari-0.0.5-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/matahari-0.0.5-1.fc13
Comment 5 Fedora Update System 2010-07-08 14:18:57 EDT
matahari-0.0.5-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update matahari'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/matahari-0.0.5-1.fc13
Comment 6 Fedora Update System 2010-07-13 16:45:16 EDT
matahari-0.0.5-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.