Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 602989 - eject no longer opens/closes CD-ROM tray.
eject no longer opens/closes CD-ROM tray.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
13
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-11 04:06 EDT by Takehiko Abe
Modified: 2010-10-27 06:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-27 06:42:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Takehiko Abe 2010-06-11 04:06:26 EDT
Description of problem:

eject no longer opens/closes CD-ROM tray. 

It ejects a mounted disc but does not open the tray when it is empty.
It does not close the tray. It used to behave the same way as 'eject -T' command
(simply because it used 'eject -T'.)

I believe the culprit is the changes made for
the upstream bug 580779  "Remove hard-coded eject in media-keys":

https://bugzilla.gnome.org/show_bug.cgi?id=580779
Git commit : 325f4f4f942cfb4ae794c32ec530942b4d84c14c

The ability to open/close the cd-rom tray with keyboard shortcut is
convenient. Please bring it back.


Version-Release number of selected component (if applicable):

gnome-settings-daemon-2.30.1-6.fc13.x86_64
Comment 1 Bastien Nocera 2010-10-27 06:42:58 EDT
You'll need to file an upstream bug about that, we won't be making behaviour changes downstream in Fedora.

Note You need to log in before you can comment on or make changes to this bug.