Bug 60301 - semi is unusable
semi is unusable
Status: CLOSED DEFERRED
Product: Red Hat Raw Hide
Classification: Retired
Component: semi (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-24 20:18 EST by Jonathan Kamens
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-11 02:50:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-02-24 20:18:19 EST
Following the directions in /usr/share/doc/semi-1.14.3/rmail-mime/README.en.gz,
I do "(setq rmail-enable-mime t)".  When I then attempt to view a MIME message
in an rmail buffer, I get the error "Feature `rmail-mime' not provided" and the
message is not displayed in any sort of MIME-formatted mode.  When I then
attempt to run "(load-library "rmail-mime")" I get "Cannot open load file mime"
because mime-view.el is trying to to "(require 'mime)" or some such thing.

Basically, semi is inadequately documented (much of the documentation there is,
is in Japanese) and does not appear to work out of the box because it depends on
a "mime" package which it does not include (and which is not listed in the
dependencies of its RPM file).
Comment 1 Jens Petersen 2002-02-24 21:43:19 EST
Can I assume you're using Emacs, not XEmacs?

My first reaction is probably better not to use RMail unless you really want to.
 RMail (the original Emacs mail program) is these days more of historic value
IMHO. I recommend using gnus (included with both emacs and xemacs), or mew or wl
(available in separate packages).  They all have reasonably good MIME support.
VMail in XEmacs in also a nice MUA with mime support.

I'll take a look at this in due course, though since semi is not being actively
worked on these days, unless it's a packaging problem it probably won't be that
easy to fix.
Comment 2 Jonathan Kamens 2002-02-24 21:45:57 EST
Yes, I am using GNU Emacs.

I have been using Rmail for over a decade.  I have no desire to change.  Ditto
for GNU Emacs vs. XEmacs.

If semi is not going to be made to work properly, then it should be removed from
the RHL distribution.
Comment 3 Jens Petersen 2002-02-24 22:01:35 EST
Ok, if you're a long-time then I understand better.

semi is known is be hmmm "somewhat broken" at best.  The oroginal author wanted
to have it included in gnus, but the gnus maintainer would have none of it...

Currently semi is only in the distribution since it's required by wl (another
Japanese made mua for emacsen).  Perhaps semi should just be made a part of wl
and not be in a separate package.
Comment 4 Jens Petersen 2002-02-28 04:55:26 EST
For the time being I have removed rmail-mime (and emh) from semi, since they
does seem to be much used.  RMail in Emacs now has some MIME support, have you
tried that?
Comment 5 Jonathan Kamens 2002-02-28 12:33:07 EST
As far as I can tell, the only Rmail MIME support that comes with the Emacs
distribution is support for decoding charsets in MIME automatically.  That's
much less than what I need.  I want to actually handle viewing attachments in
incoming messages and adding attachments to outgoing messages.  I've got code
which does that, which I obtained by downloading some really old, no longer
maintained Emacs mime stuff from the Net and hacking it up to actually work with
Emacs 21, but I was hoping that somebody had actually added supported,
maintained code for MIME within Rmail so I could stop using my gross hack.
Comment 6 Jens Petersen 2002-03-01 02:24:02 EST
Tagoh told me that it is better not to (setq rmail-enable-mime t) when using
rmail-mime with rmail.  You could try that.

I still recommend switching to a newer and better maintained MUA, but I know old
habits die hard....
Comment 7 Jonathan Kamens 2002-03-01 10:20:13 EST
As I said, I just followed the directions in the README file.  If they're wrong,
they need to be fixed.  Perhaps that's a better fix than removing rmail-mime
from the semi RPM?
Comment 8 Jens Petersen 2002-03-03 21:55:46 EST
Yeah, but i guess that depends on whether rmail-mime is of any use or not.
Comment 9 Jens Petersen 2002-03-27 10:19:47 EST
Closing this for now.  Did you find rmail-mime to be useful?

Note You need to log in before you can comment on or make changes to this bug.