Bug 603013 - [abrt] accessibility crash in accessibility::Document::getParagraph
[abrt] accessibility crash in accessibility::Document::getParagraph
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openoffice.org (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Caolan McNamara
desktop-bugs@redhat.com
abrt_hash:04141b1103921b3855bb8504cca...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-11 05:32 EDT by Tomas Pelka
Modified: 2010-11-10 16:16 EST (History)
1 user (show)

See Also:
Fixed In Version: openoffice.org-3.2.0-12.9.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:16:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (61.29 KB, text/plain)
2010-06-11 05:32 EDT, Tomas Pelka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 112363 None None None Never

  None (edit)
Description Tomas Pelka 2010-06-11 05:32:32 EDT
abrt version: 1.1.4
architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/openoffice.org3/program/scalc.bin -calc file:///home/tpelka/Desktop/Untitled%201.ods
component: openoffice.org
crash_function: is
executable: /usr/lib64/openoffice.org3/program/scalc.bin
global_uuid: 04141b1103921b3855bb8504cca993f532d9a59d
kernel: 2.6.32-25.el6.x86_64
package: openoffice.org-calc-1:3.2.0-12.4.el6
rating: 4
reason: Process /usr/lib64/openoffice.org3/program/scalc.bin was killed by signal 11 (SIGSEGV)
release: Red Hat Enterprise Linux release 6.0 Beta (Santiago)

How to reproduce
-----
1. Enable record (Edit->Changes->Record)
2. Try to add comment to record (Edit->Changes->Comment)
3.
Comment 1 Tomas Pelka 2010-06-11 05:32:35 EDT
Created attachment 423194 [details]
File: backtrace
Comment 3 RHEL Product and Program Management 2010-06-11 06:03:22 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Caolan McNamara 2010-06-11 06:04:13 EDT
accessibility related according to the stack
Comment 5 Caolan McNamara 2010-06-11 07:57:46 EDT
Can't reproduce this. Are you able to get it to happen reproducibly ? Definitely accessibility, and probably some life-cycle cockup.
Comment 6 Caolan McNamara 2010-06-11 08:02:40 EDT
aha, hang on, see it
Comment 7 Caolan McNamara 2010-06-14 05:32:39 EDT
To reproduce have accessibility enabled and in the dialog from edit->changes->comment write about 30 lines and it should crash around line 21 or thereabouts.
Comment 10 releng-rhel@redhat.com 2010-11-10 16:16:47 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.