Bug 603042 - Trace back displayed while using invalid username and password for “consumer atom “
Summary: Trace back displayed while using invalid username and password for “consumer ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin   
(Show other bugs)
Version: 0.5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Bryan Kearney
QA Contact: Katello QA List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-11 12:01 UTC by spandey
Modified: 2018-12-10 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-12-10 15:37:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description spandey 2010-06-11 12:01:41 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100%

Prequisities : 
Standalone candlepin configured by Fog 
sm version : 63 

Steps to repro : 

Login to the Rhel 6 client with valid credentials 
register client to candlepin 
Login to candlepin host with valid credentails and execute following command 

curl -k -u jsomara:redhat --header "Content-type: application/json" --header "Accept: application/atom+xml" https://localhost:8443/candlepin/consumers/2d773cd2-8899-4a98-8edf-27fdf3662086/atom


Expected Result : 
Message should display invalid USER and PASSWORD

Actual result : 
[root@localhost ~]curl -k -u jsomara:redhat --header "Content-type: application/json" --header "Accept: application/atom+xml" https://localhost:8443/candlepin/consumers/2d773cd2-8899-4a98-8edf-27fdf3662086/atom

<html><head><title>Apache Tomcat/6.0.20 - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 500 - </h1><HR size="1" noshade="noshade"><p><b>type</b> Exception report</p><p><b>message</b> <u></u></p><p><b>description</b> <u>The server encountered an internal error () that prevented it from fulfilling this request.</u></p><p><b>exception</b> <pre>org.jboss.resteasy.spi.UnhandledException: org.jboss.resteasy.spi.WriterException: java.lang.NullPointerException

	org.jboss.resteasy.core.SynchronousDispatcher.writeFailure(SynchronousDispatcher.java:345)

Comment 1 wes hayutin 2010-06-11 19:16:45 UTC
not a bug..
and or verified..

passwd's are clear txt will open a bug on that


2 07:22:44 [http-8443-1] DEBUG org.fedoraproject.candlepin.resteasy.interceptor.AuthInterceptor - Authentication check for /consumers/4746d3fe-93bc-43f8-8bd0-e833adebdade/atom
Jun 12 07:22:44 [http-8443-1] DEBUG org.fedoraproject.candlepin.resteasy.interceptor.BasicAuth - check for: asdfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffasdfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffasdfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffasdfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffff - asdfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffff
Jun 12 07:22:44 [http-8443-1] DEBUG org.fedoraproject.candlepin.resteasy.interceptor.SSLAuth - no certificate was present to authenticate the client
Jun 12 07:22:44 [http-8443-1] DEBUG org.fedoraproject.candlepin.servlet.filter.logging.LoggingFilter - ====Response====
Jun 12 07:22:44 [http-8443-1] DEBUG org.fedoraproject.candlepin.servlet.filter.logging.LoggingFilter - Status: 401
Jun 12 07:22:44 [http-8443-1] DEBUG org.fedoraproject.candlepin.servlet.filter.logging.LoggingFilter - Response Body:<?xml version="1.0" encoding="UTF-8" standalone="yes"?><exceptionMessage><displayMessage>Invalid username or password</displayMessage></exceptionMessage>
Jun 12 07:24:01 [http-8443-1] DEBUG org.fedoraproject.candlepin.servlet.filter.logging.LoggingFilter - Request: 'GET https://10.16.120.142:8443/candlepin/consumers/4746d3fe-93bc-43f8-8bd0-e833adebdade/atom'
Jun 12 07:24:01 [http-8443-1] DEBUG org.fedoraproject.candlepin.servlet.filter.logging.LoggingFilter - ====RequestBody====
Jun 12 07:24:01 [http-8443-1] DEBUG org.fedoraproject.candlepin.servlet.filter.logging.LoggingFilter - 
Jun 12 07:24:01 [http-8443-1] DEBUG org.fedoraproject.candlepin.servlet.filter.logging.LoggingFilter - ====Headers====
Jun 12 07:24:01 [http-8443-1] DEBUG org.fedoraproject.candlepin.servlet.filter.logging.LoggingFilter - host:  10.16.120.142:8443
Jun 12 07:24:01 [http-8443-1] DEBUG org.fedoraproject.candlepin.servlet.filter.logging.LoggingFilter - user-agent:  Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100330 Fedora/3.5.9-2.fc12 Firefox/3.5.9
Jun 12 07:24:01 [http-8443-1] DEBUG org.fedoraproject.candlepin.servlet.filter.logging.LoggingFilter - accept:  text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Jun 12 07:24:01 [http-8443-1] DEBUG org.fedoraproject.candlepin.servlet.filter.logging.LoggingFilter - accept-language:  en-us,en;q=0.5
Jun 12 07:24:01 [http-8443-1] DEBUG org.fedoraproject.candlepin.servlet.filter.logging.LoggingFilter - accept-encoding:  gzip,deflate
Jun 12 07:24:01 [http-8443-1] DEBUG org.fedoraproject.candlepin.servlet.filter.logging.LoggingFilter - accept-charset:  ISO-8859-1,utf-8;q=0.7,*;q=0.7
Jun 12 07:24:01 [http-8443-1] DEBUG org.fedoraproject.candlepin.servlet.filter.logging.LoggingFilter - keep-alive:  300
Jun 12 07:24:01 [http-8443-1] DEBUG org.fedoraproject.candlepin.servlet.filter.logging.LoggingFilter - connection:  keep-alive
Jun 12 07:24:01 [http-8443-1] DEBUG org.fedoraproject.candlepin.servlet.filter.logging.LoggingFilter - authorization:  Basic YWRtaW46V0VFRUVFRUVFRUVFRUVFRUVFRUVFRUVFRUVFRUVFRVNTU1NTU1NTU1NTU1NTU1NTU1NTU1NTU1NTU1NTU1NTUw==
Jun 12 07:24:01 [Finalizer] DEBUG org.fedoraproject.candlepin.auth.interceptor.SecurityInterceptor - Invoked.
Jun 12 07:24:01 [Finalizer] DEBUG org.fedoraproject.candlepin.auth.interceptor.SecurityInterceptor - com.google.inject.InterceptorStackCallback$InterceptedMethodInvocation
Jun 12 07:24:01 [Finalizer] DEBUG org.fedoraproject.candlepin.auth.interceptor.SecurityInterceptor - 0
Jun 12 07:24:01 [Finalizer] DEBUG org.fedoraproject.candlepin.auth.interceptor.SecurityInterceptor - Method annotation: null
Jun 12 07:24:01 [http-8443-1] DEBUG org.fedoraproject.candlepin.resteasy.interceptor.AuthInterceptor - Authentication check for /consumers/4746d3fe-93bc-43f8-8bd0-e833adebdade/atom
Jun 12 07:24:01 [http-8443-1] DEBUG org.fedoraproject.candlepin.resteasy.interceptor.BasicAuth - check for: admin - WEEEEEEEEEEEEEEEEEEEEEEEEEEEEEESSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSS
Jun 12 07:24:01 [http-8443-1] DEBUG org.fedoraproject.candlepin.resteasy.interceptor.SSLAuth - no certificate was present to authenticate the client
Jun 12 07:24:01 [http-8443-1] DEBUG org.fedoraproject.candlepin.servlet.filter.logging.LoggingFilter - ====Response====
Jun 12 07:24:01 [http-8443-1] DEBUG org.fedoraproject.candlepin.servlet.filter.logging.LoggingFilter - Status: 401
Jun 12 07:24:01 [http-8443-1] DEBUG org.fedoraproject.candlepin.servlet.filter.logging.LoggingFilter - Response Body:<?xml version="1.0" encoding="UTF-8" standalone="yes"?><exceptionMessage><displayMessage>Invalid username or password</displayMessage></exceptionMessage>

Comment 3 John Sefler 2011-05-04 14:40:31 UTC
Group move of VERIFIED Candlepin component bugs to RELEASE_PENDING

Comment 5 Bryan Kearney 2018-12-10 15:37:00 UTC
I am closing out some old bugs from 2015. So, closing these out as current release. If this is still an issue for me, please reach out.


Note You need to log in before you can comment on or make changes to this bug.