Bug 60305 - ipcs fails to list all shared memory segments on alpha platform
ipcs fails to list all shared memory segments on alpha platform
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.2
alphaev6 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
http://www.compaq.com/products/softwa...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-25 00:11 EST by Warren Mansur
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 18:46:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Mansur 2002-02-25 00:11:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
ipcs does not list all of the shared memory segments on any alpha machine 
running Redhat 7.1 or later (versions previous to 7.1 are untested).  It 
appears to only list one or two shared memory segments and not list the rest, 
or sometimes it simply does not list any.  It then becomes impossible to delete 
the shared memory segments that are not shown because getting their key is 
impossible.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
ON ALPHA PLATFORM
1. Run any program that creates a shared memory segment for a user (the program 
given by the URL above creates a shared memory segment when it initializes)
2. Run the same program with another user
3. Execute 'ipcs -m'
4. Execute 'ipcs -u'

Actual Results:  For #3 in the steps to reproduce, it will either not show any 
memory segments or may show just one.  For #4, it will indicate that there are 
2 outstanding shared memory segments (or more if other programs have some as 
well such as gnome).

Expected Results:  You should see each user's shared memory segments with their 
key and so on after executing #3.  #4's output is correct.

Additional info:

[after executing the steps to reproduce, here is what the output is (with 
username and node name removed for security purposes)].  Note that directly 
listing the shared memory segments shows zero segments, while summarizing the 
shared memory segments indicates there are 2 segments.  There is clearly a 
mismatch here.

[user@computer ~]$ ipcs -m

------ Shared Memory Segments --------
key       shmid     owner     perms     bytes     nattch    status

[user@computer ~]$ ipcs -u

------ Shared Memory Status --------
segments allocated 2
pages allocated 40
pages resident  40
pages swapped   0
Swap performance: 0 attempts     0 successes

------ Semaphore Status --------
used arrays = 0
allocated semaphores = 0

------ Messages: Status --------
allocated queues = 0
used headers = 0
used space = 0 bytes

[user@computer ~]$
Comment 1 Jakub Jelinek 2004-10-03 18:46:56 EDT
ipcs are part of util-linux, not binutils.
But RHL for Alpha platform is not supported anymore.
If you are able to reproduce this with some currently supported
distribution, please reopen.

Note You need to log in before you can comment on or make changes to this bug.