Bug 60307 - pcmcia ide-scsi fails to attach as scsi cd-rw
pcmcia ide-scsi fails to attach as scsi cd-rw
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-25 02:44 EST by Charles Bibber
Modified: 2015-01-04 17:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 03:04:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Bibber 2002-02-25 02:44:36 EST
Description of Problem: EXP CRW-785 CD-RW station attached via PCMCIA fails to
work in ide-scsi IDE ATAPIemulation mode at 7.2 cdrom base level and with all
available rpms applied a/o 2/25/2002.. /etc/lilo.conf contains
'append="hdb=ide-scsi hdg=ide-scsi"'  /etc/rc.d/rc.local contains 'modprobe
imm'  'modprobe ide-scsi'  /etc/modules.conf contains 'options ide-cd
ignore='hdb hdg'  '  and yet system attempts to attach drive as hdb ide drive.
1st drive (internal 365xd laptop TEAC 4x CD read-only) attaches as scd0  and
works read-only. Have also attempted to only define hdg in 3 files above, hdb
forks fine as non-scsi and hdg has same problem. cardmgr version is 3.1.24 on
RH6.2 and cardmgr version 3.1.22 on RH7.2. Seems to be very much PCMCIA related
as drive and cardmgr are not loaded or powered up into PCMCIA comes active.
There are differences between the config files between 6.2 and 7.2. Have also
noticed that when hdb is defined as SCSI, driver doesn't load until mounted.. 
FSTAB for hdg is defined automatically when PCMCIA comes to life as hdg
(/dev/cdrom1  /mnt/cdrom1)  attempt to mount results in "mount: /dev/cdrom1 is
not a valid block device". On RH6.2 loads as exp cd940 "vendor:LG MODEL:CD-RW
CED8080B .  Notable on RH7.2 on reboot of system without power off error on
restart "./config.opts line 8:no functional bindings" and on sytem shutdown
cardmgr gets error 1 in cardmgr/pcmcia shutdown..  Also cdrecord -scanbus NEVER
FINDS PCMCIA attached EXP CD-RW drive..
Have tried a complete reinstall of RH7.2 via CDROM, fails at base level and
after apply of ALL available RPM's from RHN as of 2/25/2002.


Version-Release number of selected component (if applicable): RedHat i386 7.2
base and RedHat i386 7.2 with ALL available RHN RPMS for system as of 2/25/2002. 


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results: Should load and install as on RedHat 6.2


Additional Information: Will provide additional information on demand by e-mail
Request.
Comment 1 Charles Bibber 2002-03-01 18:46:41 EST
I have applied the new kernel rpms for 2.4.9-31 and the problem still exists.
Comment 2 Charles Bibber 2002-03-02 16:28:15 EST
Found a workaround
changed /etc/rc.d/rc.local from 
'modprobe imm' 
'modprobe ide-scsi' 
to 
'modprobe imm' 
'modprobe -r ide-scsi'
'modprobe ide-scsi'
The system now picks up the 2nd cd-rom (CD-RW) drive and it works. cdrecord
-scanbus finds Both the r/o and r/w cdrom drives (as SCSI) and X-CD-Roast
configures and works. Still getting the other errors on reboot and shutdown sooo
there is still some sort of a problem.

Note You need to log in before you can comment on or make changes to this bug.