Bug 603089 - [abrt] crash in java-1.6.0-openjdk-devel-1:1.6.0.0-38.b18.fc12: raise: Process /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/bin/jstat was killed by signal 6 (SIGABRT)
Summary: [abrt] crash in java-1.6.0-openjdk-devel-1:1.6.0.0-38.b18.fc12: raise: Proces...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
(Show other bugs)
Version: 12
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Deepak Bhole
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3d5d55d3b240a8997752ebb630e...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-11 14:06 UTC by Jeremy Whiting
Modified: 2010-08-12 16:17 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-12 16:17:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (14.39 KB, text/plain)
2010-06-11 14:06 UTC, Jeremy Whiting
no flags Details

Description Jeremy Whiting 2010-06-11 14:06:31 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: jstat -gcutil -t -h12 3052 5s
comment: when I started the jstat process I double checked the jstat process was not atatched to an identical java process
component: java-1.6.0-openjdk
crash_function: raise
executable: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/bin/jstat
global_uuid: 3d5d55d3b240a8997752ebb630ef247677b3bc18
kernel: 2.6.32.12-115.fc12.x86_64
package: java-1.6.0-openjdk-devel-1:1.6.0.0-38.b18.fc12
rating: 4
reason: Process /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/bin/jstat was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. start several java processes, five in total
2. attatch a jstat process to three of the java processes
3. sample jstat command execution with flags
jstat -gcutil -t -h12 2766 5s > application-gc-detailed.txt &

Comment 1 Jeremy Whiting 2010-06-11 14:06:33 UTC
Created attachment 423289 [details]
File: backtrace

Comment 2 Andrew Su 2010-08-12 16:17:45 UTC
I was not able to create this crash, I ran 5 java programs all of which does a while(true) so that it doesn't exit, then I used jstat on three of them. I didn't receive any problems, but looking at your backtrace, it says you have run out memory (thread 1 frame 4).

Closing as not a bug. However if you feel otherwise, feel free to reopen this bug.


Note You need to log in before you can comment on or make changes to this bug.