Bug 603109 - SELinux is preventing /usr/sbin/named "read" access on db.cache.
SELinux is preventing /usr/sbin/named "read" access on db.cache.
Status: CLOSED DUPLICATE of bug 602992
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-11 10:43 EDT by Mijax
Modified: 2010-06-11 10:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-11 10:53:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mijax 2010-06-11 10:43:44 EDT
Summary:

SELinux is preventing /usr/sbin/named "read" access on db.cache.

Detailed Description:

SELinux denied access requested by named. It is not expected that this access is
required by named and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:named_t:s0
Target Context                system_u:object_r:default_t:s0
Target Objects                db.cache [ file ]
Source                        named
Source Path                   /usr/sbin/named
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bind-9.6.2-4.P2.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-116.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.12-115.fc12.i686.PAE
                              #1 SMP Fri Apr 30 20:14:08 UTC 2010 i686 athlon
Alert Count                   2
First Seen                    Fri 11 Jun 2010 06:51:38 AM IRDT
Last Seen                     Fri 11 Jun 2010 06:54:13 AM IRDT
Local ID                      fb98c2e8-39df-4131-a4d2-328b986b05bf
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1276223053.578:6): avc:  denied  { read } for  pid=1746 comm="named" name="db.cache" dev=sda5 ino=134710 scontext=system_u:system_r:named_t:s0 tcontext=system_u:object_r:default_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1276223053.578:6): arch=40000003 syscall=5 success=no exit=-13 a0=b784cff8 a1=0 a2=1b6 a3=5f7e49 items=0 ppid=1744 pid=1746 auid=4294967295 uid=25 gid=25 euid=25 suid=25 fsuid=25 egid=25 sgid=25 fsgid=25 tty=(none) ses=4294967295 comm="named" exe="/usr/sbin/named" subj=system_u:system_r:named_t:s0 key=(null)
Comment 1 Mijax 2010-06-11 10:46:00 EDT
This alert showed After doing:
# restorecon -R -v /var/named  
that  Miroslav Grepl guided here:
https://bugzilla.redhat.com/show_bug.cgi?id=602992
Comment 2 Daniel Walsh 2010-06-11 10:53:22 EDT
Lets keep these all in the same bug.

*** This bug has been marked as a duplicate of bug 602992 ***

Note You need to log in before you can comment on or make changes to this bug.