Bug 60311 - IDE tape driver does not work properly
IDE tape driver does not work properly
Status: CLOSED DUPLICATE of bug 54517
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-25 07:54 EST by James Newlin
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-26 09:32:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Newlin 2002-02-25 07:54:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
IDE tape drive inside the RedHat kernels 2.4.9-6 and 2.4.9-21 does not work 
properly.   It does work under RedHat kernel 2.4.7-10.   System is Intel 
Pentium III 1.0GHz in Intel I815EGEW mainboard using primary IDE controller 
with CD-ROM as master and TAPE as slave drive using 80pin IDE cable.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot up 2.4.9 kernel
2. start CPIO or TAR to write data to tape
3. watch it not work.
	

Actual Results:  Errors listed in /var/adm/messages.   Initially the drive 
status LED will remain on while the system is timing out.  After the timeout 
the drive will start to rewind then report "end of medium found. insert next 
tape."

Expected Results:  Create tape with hard drive contents on it.

Additional info:

Feb 25 07:25:23 beckman kernel: ide-tape: Dumping ATAPI Identify Device tape 
parameters
Feb 25 07:25:23 beckman kernel: ide-tape: Protocol Type: <6>ATAPI
Feb 25 07:25:23 beckman kernel: ide-tape: Device Type: 1 - <6>Streaming Tape 
Device
Feb 25 07:25:23 beckman kernel: ide-tape: Removable: Yes
Feb 25 07:25:23 beckman kernel: ide-tape: Command Packet DRQ Type: 
<6>Accelerated DRQ
Feb 25 07:25:23 beckman kernel: ide-tape: Command Packet Size: <6>12 bytes
Feb 25 07:25:23 beckman kernel: ide-tape: Model: Seagate STT20000A
Feb 25 07:25:23 beckman kernel: ide-tape: Firmware Revision: 8A51
Feb 25 07:25:23 beckman kernel: ide-tape: Serial Number: 
Feb 25 07:25:23 beckman kernel: ide-tape: Write buffer size: 372736 bytes
Feb 25 07:25:23 beckman kernel: ide-tape: DMA: Yes
Feb 25 07:25:23 beckman kernel: ide-tape: LBA: Yes
Feb 25 07:25:23 beckman kernel: ide-tape: IORDY can be disabled: Yes
Feb 25 07:25:23 beckman kernel: ide-tape: IORDY supported: Yes
Feb 25 07:25:23 beckman kernel: ide-tape: ATAPI overlap supported: No
Feb 25 07:25:23 beckman kernel: ide-tape: PIO Cycle Timing Category: 2
Feb 25 07:25:23 beckman kernel: ide-tape: DMA Cycle Timing Category: 2
Feb 25 07:25:23 beckman kernel: ide-tape: Single Word DMA supported modes: <6>0 
<6>1 <6>2 <6>(active) <6>
Feb 25 07:25:23 beckman kernel: ide-tape: Multi Word DMA supported modes: <6>0 
<6>1 <6>2 <6>(active) <6>
Feb 25 07:25:23 beckman kernel: ide-tape: Enhanced PIO Modes: Mode 3
Feb 25 07:25:23 beckman kernel: ide-tape: Minimum Multi-word DMA cycle per 
word: <6>120 ns
Feb 25 07:25:23 beckman kernel: ide-tape: Manufacturer's Recommended Multi-word 
cycle: <6>120 ns
Feb 25 07:25:23 beckman kernel: ide-tape: Minimum PIO cycle without IORDY: 
<6>120 ns
Feb 25 07:25:23 beckman kernel: ide-tape: Minimum PIO cycle with IORDY: <6>120 
ns
Feb 25 07:25:23 beckman kernel: ide-tape: hdb <-> ht0: Seagate STT20000A rev 
8A51
Feb 25 07:25:23 beckman kernel: ide-tape: Dumping the results of the MODE SENSE 
packet command
Feb 25 07:25:23 beckman kernel:ide-tape: Mode Parameter Header:
Feb 25 07:25:23 beckman kernel: ide-tape: Mode Data Length - 23
Feb 25 07:25:23 beckman kernel: ide-tape: Medium Type - 183
Feb 25 07:25:23 beckman kernel: ide-tape: Device Specific Parameter - 16
Feb 25 07:25:23 beckman kernel: ide-tape: Block Descriptor Length - 0
Feb 25 07:25:23 beckman kernel: ide-tape: Capabilities and Mechanical Status 
Page:
Feb 25 07:25:23 beckman kernel: ide-tape: Page code - 42
Feb 25 07:25:23 beckman kernel: ide-tape: Page length - 18
Feb 25 07:25:23 beckman kernel: ide-tape: Read only - No
Feb 25 07:25:23 beckman kernel: ide-tape: Supports reverse space - Yes
Feb 25 07:25:23 beckman kernel: ide-tape: Supports erase initiated formatting - 
No
Feb 25 07:25:23 beckman kernel: ide-tape: Supports QFA two Partition format - 
Yes
Feb 25 07:25:23 beckman kernel: ide-tape: Supports locking the medium - No
Feb 25 07:25:23 beckman kernel: ide-tape: The volume is currently locked - No
Feb 25 07:25:23 beckman kernel: ide-tape: The device defaults in the prevent 
state - No
Feb 25 07:25:23 beckman kernel: ide-tape: Supports ejecting the medium - No
Feb 25 07:25:23 beckman kernel: ide-tape: Supports error correction - Yes
Feb 25 07:25:23 beckman kernel: ide-tape: Supports data compression - No
Feb 25 07:25:23 beckman kernel: ide-tape: Supports 512 bytes block size - Yes
Feb 25 07:25:23 beckman kernel: ide-tape: Supports 1024 bytes block size - No
Feb 25 07:25:23 beckman kernel: ide-tape: Supports 32768 bytes block size / 
Restricted byte count for PIO transfers - No
Feb 25 07:25:23 beckman kernel: ide-tape: Maximum supported speed in KBps - 1000
Feb 25 07:25:23 beckman kernel: ide-tape: Continuous transfer limits in blocks -
 108
Feb 25 07:25:23 beckman kernel: ide-tape: Current speed in KBps - 1000
Feb 25 07:25:23 beckman kernel: ide-tape: Buffer size - 331776
Feb 25 07:25:23 beckman kernel: ide-tape: Adjusted block size - 512
Feb 25 07:25:23 beckman kernel: ide-tape: hdb <-> ht0: 1000KBps, 6*54kB buffer, 
9720kB pipeline, 110ms tDSC, DMA
Feb 25 07:25:23 beckman kernel: ide-tape: Reached idetape_chrdev_open
Feb 25 07:26:29 beckman kernel: hdb: timeout waiting for DMA
Feb 25 07:26:29 beckman kernel: ide_dmaproc: chipset supported ide_dma_timeout 
func only: 14
Feb 25 07:26:29 beckman kernel: hdb: status timeout: status=0xd0 { Busy }
Feb 25 07:26:29 beckman kernel: hdb: drive not ready for command
Feb 25 07:26:29 beckman kernel: hdb: ATAPI reset complete
Feb 25 07:26:29 beckman kernel: ide-tape: ht0: I/O error, pc =  a, key =  2, 
asc =  4, ascq =  1
Feb 25 07:26:32 beckman last message repeated 180 times
Feb 25 07:26:32 beckman kernel: ide-tape: ht0: I/O error, pc = 10, key =  2, 
asc =  4, ascq =  1
Feb 25 07:26:32 beckman kernel: ide-tape: ht0: I/O error, pc = 1b, key =  2, 
asc = 3a, ascq =  0
Feb 25 07:26:32 beckman kernel: ide-tape: ht0: I/O error, pc =  1, key =  2, 
asc =  4, ascq =  1
Comment 1 James Newlin 2002-02-26 09:32:21 EST
Found out that if you add "ide=nodma" to the kernel line, the 2.4.9 kernels 
work correctly.
Comment 2 Pete Zaitcev 2002-02-26 13:57:10 EST
The "ide=nodma" is a little too harsh, because it kills DMA
on IDE disks too. A better workaround is to use hdparm -d0 /dev/hdb.

This is an ongoing problem somewhere in bowels of IDE framework.
Apparently, the old 2.2 IDE did not hit hw too hard.

Last note - I suggest to use ide-scsi and st instead of ide-tape.
The latter is a poorly implemented driver, with bugs crawling
all over it.


*** This bug has been marked as a duplicate of 54517 ***

Note You need to log in before you can comment on or make changes to this bug.