Bug 603129 - mlton incorrectly requires perl
Summary: mlton incorrectly requires perl
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mlton   
(Show other bugs)
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Goode
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-11 15:43 UTC by Adam Goode
Modified: 2011-08-12 16:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-12 16:37:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Goode 2010-06-11 15:43:31 UTC
Description of problem:
Do to limitations of RPM, mlton requires perl just because there are some non-essential perl scripts installed.

We currently strip out the perl() requires/provides themselves, but can't strip out the perl requirement itself, at least until RPM's dependency generator allows it.

See https://fedoraproject.org/wiki/Packaging:AutoProvidesAndRequiresFiltering (can't currently use this because mlton is a binary package).

Comment 1 Bug Zapper 2010-07-30 12:06:04 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Adam Goode 2011-08-12 16:37:12 UTC
This should be fixed with changes in rawhide enabled by the rpm 4.9 dependency filtering.


Note You need to log in before you can comment on or make changes to this bug.