Bug 603146 - Evolution - imap account disappears
Summary: Evolution - imap account disappears
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-11 16:49 UTC by chris
Modified: 2011-06-27 18:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-27 18:01:39 UTC


Attachments (Terms of Use)
This is Evolution upon opening/starting the program (43.97 KB, image/png)
2010-06-11 16:49 UTC, chris
no flags Details
This is Evolution after being idle for some period. (16.48 KB, image/png)
2010-06-11 16:51 UTC, chris
no flags Details

Description chris 2010-06-11 16:49:10 UTC
Created attachment 423335 [details]
This is Evolution upon opening/starting the program

Description of problem:
 
  After opening Evolution and having it open in the background for a period of time (3 to 10 minutes - not timed).  The Imap account inbox and subdirectories disappear.  Disabeling the account an re-enabling the account brings back the inbox and subdirectories, but now the inbox only shows un-read items (Not my desired setting).

  This did not occur in F12.  The system (except the /home directory) was reformatted and reinstalled.

Version-Release number of selected component (if applicable):
evolution-2.30.1-8.fc13.x86_64 (latest by yum)


How reproducible:
Every time Evolution is opened and allowed to stay open in the background.

Steps to Reproduce:
1. Open Evolution
2. Use other programs or walk away
3. 
  
Actual results:
imap account inbox and subs disappear

Expected results:
imap account inbox and subs *do not* disappear

Additional info:
every time Evolution is closed and re-opened the account displays as expected.

Comment 1 chris 2010-06-11 16:51:43 UTC
Created attachment 423336 [details]
This is Evolution after being idle for some period.

Comment 2 Milan Crha 2010-06-15 17:26:46 UTC
Thanks for a bug report. I do no recall seeing this myself or anything similar before, neither a similar bug. Could you try to close Evolution, and then move away (to some other directory) your local IMAP cache, and let recreate its content from scratch, whether it'll help, please?

The local IMAP cache is at
   ~/.evolution/mail/imap/<account>
thus renaming the folder to
   ~/.evolution/mail/imap/<account>.broken
or similar may work very well. The only disadvantage of this is that the all folder hierarchy and messages will be fetched again, when you select them.

Comment 3 chris 2010-06-16 12:37:04 UTC
I closed evolution, renamed the IMAP cache folder to .broken as suggested above and opened evolution.  Took a while to re-fetch the messages.  Then left for the day and left evolution open... this morning - empty.  After reopening evolution, the account is as it should be.

Comment 4 chris 2010-06-16 12:41:41 UTC
I"m attempting to rename ~/.evolution to ~/.evolution.broken and "start over".  If unsuccessful, I will un-install evolution and re-install.  I like evolution and want it to work!

Comment 5 Milan Crha 2010-06-16 14:40:40 UTC
(In reply to comment #4)
> I"m attempting to rename ~/.evolution to ~/.evolution.broken and "start over". 
> If unsuccessful, I will un-install evolution and re-install.    

That may not help, at least not with this IMAP issue.

a) When you go to Edit->Preferences->Mail accounts, what is the "Protocol" column value for your account?

b) Do you use also other than IMAP accounts?

c) How is your IMAP account configured (what is checked, what isn't)?

d) There is an IMAP+ provider available in Evolution 2.30.x, which is rather experimental and quite new, but it knows how to communicate to the server. Could you try to configure another IMAP account, this time with IMAP+, which will also connect to your IMAP server you've an issue with, please?

Comment 6 chris 2010-06-18 15:51:49 UTC
I have seemed to work around the problem.  I renamed the ~/.evolution directory, that didn't work so I removed evolution then re-installed and chose IMAP+ (prior to reading your suggestion). yuck, but it worked, I have not had the disappearing folders in over 8 hours (yesterday).

Background I didn't provide previously, I upgraded from F12 but not by using either the "upgrade option" from the media nor via yum.  I deleted everything but the /home directory, created new directory tree, then installed F13 from DVD media.

As a real plus to me... <sarcasm> i subsequently deleted the ~/.evolution.broken, luckily it's IMAP.

The protocol was imap, now it is imapx.  The check-boxes were as default from F12, as it is now deleted I cannot confirm. I had (have) no other accounts, I don't even use the "local account" functionality (as best a possible) as I try to keep everything server side.

One thing I found interesting is when I renamed the ~/.evolution directory and started evolution, I didn't have to re-create my account (sure, the mail had to be re-downloaded but questions about settings).  When I removed evolution and re-installed, I did have to re-create my account (using the "Wizard").  Like some account information is stored outside of ~/.evolution or evolution looks for ~/.evolution type information.

Comment 7 Steven Haigh 2010-08-19 13:52:50 UTC
You're doing better that me!

I've tried just about everything I can think of to get my IMAP inbox to show. 

I've tried:
1) rm -fR ~/.evolution
2) rm -fR ~/.evolution; rm -fR ~/.gconf/apps/evolution
3) Account setup as IMAP
4) Account setup as IMAP+
5) Disabled the account and reenabled it.

The account is created with SSL enabled.

I still haven't been able to make the inbox on my account show.

Anyone have any insights or workarounds?

Comment 8 Steven Haigh 2010-08-19 13:54:25 UTC
Oh, I should clarify that all subfolders appear - just not the inbox.

Comment 9 Milan Crha 2010-08-23 14:14:36 UTC
Could you go to Folder->Subscriptions and see whether the Inbox is subscribed? As far as I know Evolution expects it to be subscribed, to show its content.

Comment 10 Steven Haigh 2010-08-28 13:27:53 UTC
When I look at the folder subscriptions, the inbox does not show either. This makes it impossible to check if it is subscribed or not :(

Comment 11 Steven Haigh 2010-09-01 13:53:06 UTC
I managed to find the cause of this - by modifying an IMAP server option.

In /etc/dovecot.conf:
namespace private {
    ## Change this to YES or uncomment it.
    inbox = yes
}

Restart dovecot on the mail server and the INBOX will now show and function as it should.

I still believe this is a bug against Evolution though - as no other mail client (Outlook 2007/2010, thunderbird, Outlook Express, RoundcubeMail, squirellmail, etc etc) requires that this option be set.

Comment 12 Bug Zapper 2011-06-02 11:12:46 UTC
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 13 Bug Zapper 2011-06-27 18:01:39 UTC
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.