Bug 603185 - On default install, guest network conflicts with KVM host NAT network
On default install, guest network conflicts with KVM host NAT network
Status: CLOSED DUPLICATE of bug 594494
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-11 15:11 EDT by Mauricio Teixeira
Modified: 2010-06-11 15:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-11 15:46:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mauricio Teixeira 2010-06-11 15:11:27 EDT
Description of problem:

On default install of RHEL 6 Snapshot 1 and above, running as KVM guest on a RHEL 5.x host, the default network configuration conflicts between guest and host.

Service libvirtd comes enabled by default, and uses 192.168.122.1 as the virbir0 interface. This is the same IP range used by the KVM host when the network is set to NAT.

Version-Release number of selected component (if applicable):

Host: RHEL 5.5, NAT network
Guest: RHEL 6 Snapshot >= 1

How reproducible:

Steps to Reproduce:
1. Install RHEL 5.5 as host.
2. Use virt-manager to create a new guest with type RHEL 6.
3. Install RHEL 6 on the guest.
4. Boot guest.
5. ping any IP on the "real" network. ping will stop after 10 packages or so.
6. service libvirtd stop
7. service network restart
8. ping works forever
  
Actual results:

After 10 ping packets or so, network communications stall.

Expected results:

Network should work out of the box.

Additional info:

I suggest there should be a way to detect if the installed system is a guest under KVM, and do one of the options:

a) disable libvirtd

or

b) use a different IP on the guest's virbr0 interface
Comment 2 RHEL Product and Program Management 2010-06-11 15:32:56 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Chris Lalancette 2010-06-11 15:46:03 EDT
(In reply to comment #0)
> Additional info:
> 
> I suggest there should be a way to detect if the installed system is a guest
> under KVM, and do one of the options:
> 
> a) disable libvirtd

You don't want to do this; you can, in theory, run guests in a guest (it's called Nested Virtualization).

> 
> or
> 
> b) use a different IP on the guest's virbr0 interface    

We actually already have a patch for this queued up for the next RHEL-6 release.  Closing as a dup.

Chris Lalancette

*** This bug has been marked as a duplicate of bug 594494 ***

Note You need to log in before you can comment on or make changes to this bug.