Bug 603189 - Missing builds for python-sphinx-0.5.1-2
Summary: Missing builds for python-sphinx-0.5.1-2
Status: CLOSED DEFERRED
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-sphinx   
(Show other bugs)
Version: el5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Michel Alexandre Salim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-11 19:42 UTC by Lev Shamardin
Modified: 2010-06-22 18:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-22 18:12:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lev Shamardin 2010-06-11 19:42:00 UTC
Description of problem:
Current pyhon-sphinx version in Fedora CVS is 0.5.1, but the builds are done only for 0.4.2. Can you please make the fresh builds and push them to updates?

Additional info:
python-eventlet package could have a -doc subpackage, if python-sphinx is updated to >= 0.5.0.

Comment 1 Toshio Ernie Kuratomi 2010-06-11 22:40:56 UTC
Kevin Fenzi just asked me about this and it's a bit tricky as we want to maintain backwards compatibility in EPEL.... which sometimes means that we can't upgrade to newer versions of packages.  Looking at the changelog alone, there appears to only be one incompatible change -- it doesn't look like it addresses API compatibility, though, just using sphinx as a toolchain.  Here's the options we have; they all start with analyzing the sphinx-0.4.2 and sphinx-0.5.0 packages to see what the actual incompatibilities are:

* Decide that there aren't any incompatibilities that are going to affect people.  Upgrade to 0.5.x

* Ask for an exception on the epel mailing list.  Listing what the incompatibilities are and what affect they'll have on people will help here.  Then upgrade to 0.5.x.

* Package a parallel installable version (probably want to move to 0.6.x or 1.0.x in the new package then), review it and get it built for epel.

* Conditionally apply this patch to eventlet so that it builds with sphinx-0.4.x
  http://toshio.fedorapeople.org/packages/eventlet-old-sphinx.patch

Comment 2 Lev Shamardin 2010-06-22 16:52:34 UTC
I think we can live with this patch for python-eventlet for now. Not sure if this bug could/should be closed, leaving this up to you.

Comment 3 Toshio Ernie Kuratomi 2010-06-22 18:12:08 UTC
If you can live with it, I'll close this.  It's a lot easier to build slightly degraded docs on EPEL-5 than to analyze all the changes between sphinx-0.4 and 0.5.x.  If other packages start needing the new sphinx we can look into upgrading again (or a parallel installable package).


Note You need to log in before you can comment on or make changes to this bug.