Bug 603196 - liberation-fonts-ttf-1.05.tar.gz is broken
liberation-fonts-ttf-1.05.tar.gz is broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-11 16:07 EDT by Peter
Modified: 2010-07-14 00:07 EDT (History)
5 users (show)

See Also:
Fixed In Version: liberation-fonts-1.05.3.20100510-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 03:37:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter 2010-06-11 16:07:40 EDT
Description of problem:

liberation-fonts-ttf-1.05.tar.gz downloaded from http://github.com/kaio/liberation-fonts/downloads is broken (I'm unable to unpack it).

How reproducible:

 $ wget 'http://github.com/downloads/kaio/liberation-fonts/liberation-fonts-ttf-1.05.tar.gz'
 $ tar xf liberation-fonts-ttf-1.05.tar.gz 
tar: Skipping to next header
tar: Error exit delayed from previous errors

.

Additional info:
BTW, link on download location at homepage (https://fedorahosted.org/liberation-fonts/) is broken: it lists http:// twice and is unclickable (http://http://github.com/kaio/liberation-fonts/downloads).
Comment 1 Jens Petersen 2010-06-15 03:30:52 EDT
Liberation fonts releases should be moved back to fedorahosted - it was not intended to be on github.
Comment 2 Fedora Update System 2010-06-15 23:23:20 EDT
liberation-fonts-1.05.3.20100510-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/liberation-fonts-1.05.3.20100510-1.fc13
Comment 3 Fedora Update System 2010-06-16 13:40:40 EDT
liberation-fonts-1.05.3.20100510-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update liberation-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/liberation-fonts-1.05.3.20100510-1.fc13
Comment 4 Peter 2010-06-16 14:30:57 EDT
Thank you. liberation-fonts-1.05.tar.gz works.

But could you clarify last bit, please:

Common practice is to put date into snapshot, not into release and thus it looks like liberation-fonts-1.05.3.20100510-1.fc13 is snapshot before 1.06 - final release. Is this assumption correct?

Also is it possible to provide both liberation-fonts and  liberation-fonts-ttf packages? In Gentoo we allow users to rebuild fonts with fontforge at will and it'll be nice either to have both package or alternatively everything in one package.

Thanks again!
Comment 5 Fedora Update System 2010-07-13 03:36:56 EDT
liberation-fonts-1.05.3.20100510-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Jens Petersen 2010-07-13 22:57:17 EDT
(In reply to comment #4)
> Common practice is to put date into snapshot, not into release and thus it
> looks like liberation-fonts-1.05.3.20100510-1.fc13 is snapshot before 1.06 -
> final release. Is this assumption correct?

Not sure, but I think we should drop date-stamps from future releases
to avoid such confusion.  Peter, I think you can take it as a release
but do report any problems. :)

> Also is it possible to provide both liberation-fonts and  liberation-fonts-ttf
> packages? In Gentoo we allow users to rebuild fonts with fontforge at will and
> it'll be nice either to have both package or alternatively everything in one
> package.

Agreed - Pravin maybe you can take note of this too.
Comment 7 Pravin Satpute 2010-07-14 00:07:36 EDT
Yes, sure
We will follow proper version mechanism instead of date stamp from now onwards for Liberation fonts.


In next release of it, i will release 2 tarball one with binary (.ttf) and other with source file .sfd (Like we are doing for Lohit)

Thanks

Note You need to log in before you can comment on or make changes to this bug.