Bug 603203 - [abrt] crash in gwibber-1:1.2.0-3.349bzr.fc12: facelib.py:765:_check_error:FacebookError: Error 4: Application request limit reached
[abrt] crash in gwibber-1:1.2.0-3.349bzr.fc12: facelib.py:765:_check_error:Fa...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gwibber (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
abrt_hash:3261f27d
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-11 16:35 EDT by Kevin J Morgan
Modified: 2010-08-19 22:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: gwibber-2.31.4-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 21:55:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.40 KB, text/plain)
2010-06-11 16:35 EDT, Kevin J Morgan
no flags Details

  None (edit)
Description Kevin J Morgan 2010-06-11 16:35:52 EDT
abrt 1.0.9 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/gwibber
component: gwibber
executable: /usr/bin/gwibber
kernel: 2.6.32.12-115.fc12.x86_64
package: gwibber-1:1.2.0-3.349bzr.fc12
reason: facelib.py:765:_check_error:FacebookError: Error 4: Application request limit reached
release: Fedora release 12 (Constantine)

backtrace
-----
facelib.py:765:_check_error:FacebookError: Error 4: Application request limit reached

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/gwibber/configui.py", line 29, in on_validate_click
    data = fb.auth.getSession()
  File "/usr/lib/python2.6/site-packages/gwibber/microblog/support/facelib.py", line 501, in getSession
    result = self._client('%s.getSession' % self._name, args)
  File "/usr/lib/python2.6/site-packages/gwibber/microblog/support/facelib.py", line 835, in __call__
    return self._parse_response(response, method)
  File "/usr/lib/python2.6/site-packages/gwibber/microblog/support/facelib.py", line 810, in _parse_response
    self._check_error(result)
  File "/usr/lib/python2.6/site-packages/gwibber/microblog/support/facelib.py", line 765, in _check_error
    raise FacebookError(response['error_code'], response['error_msg'], response['request_args'])
FacebookError: Error 4: Application request limit reached

Local variables in innermost frame:
self: <gwibber.microblog.support.facelib.Facebook object at 0x2fa2510>
response: {'error_code': 4, 'error_msg': 'Application request limit reached', 'request_args': [{'value': 'JSON', 'key': 'format'}, {'value': '<removed login code>', 'key': 'auth_token'}, {'value': '<removed key>', 'key': 'sig'}, {'value': '1.0', 'key': 'v'}, {'value': '<removed key>', 'key': 'api_key'}, {'value': 'facebook.auth.getSession', 'key': 'method'}]}

How to reproduce
-----
1.add facebook account
2.enter login code
3.hit athorize staus changes
4.crash
Comment 1 Kevin J Morgan 2010-06-11 16:35:54 EDT
Created attachment 423388 [details]
File: backtrace
Comment 2 Fedora Update System 2010-07-26 15:21:24 EDT
gwibber-2.31.2-7.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gwibber-2.31.2-7.fc12
Comment 3 Fedora Update System 2010-07-26 15:26:38 EDT
gwibber-2.31.2-7.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gwibber-2.31.2-7.fc13
Comment 4 Fedora Update System 2010-07-26 22:22:44 EDT
gwibber-2.31.2-7.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gwibber'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gwibber-2.31.2-7.fc13
Comment 5 Fedora Update System 2010-07-26 22:30:14 EDT
gwibber-2.31.2-7.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gwibber'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gwibber-2.31.2-7.fc12
Comment 6 Henri Salomäki 2010-07-31 07:09:27 EDT
Package: gwibber-1:1.2.0-3.349bzr.fc12
Architecture: x86_64
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. Add new facebook account to gwibber



Comment
-----
I tried to add new facebook account, because my first account didn't work anymore
Comment 7 Fedora Update System 2010-08-09 16:26:12 EDT
gwibber-2.31.4-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gwibber-2.31.4-1.fc12
Comment 8 Fedora Update System 2010-08-09 16:31:06 EDT
gwibber-2.31.4-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gwibber-2.31.4-1.fc13
Comment 9 Fedora Update System 2010-08-10 17:28:06 EDT
gwibber-2.31.4-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gwibber'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gwibber-2.31.4-1.fc12
Comment 10 Fedora Update System 2010-08-10 17:33:32 EDT
gwibber-2.31.4-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gwibber'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gwibber-2.31.4-1.fc13
Comment 11 Fedora Update System 2010-08-19 21:50:39 EDT
gwibber-2.31.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2010-08-19 22:05:00 EDT
gwibber-2.31.4-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.