Bug 60326 - Invalid directive line 37 of /usr/include/inttypes.h
Invalid directive line 37 of /usr/include/inttypes.h
Status: CLOSED DUPLICATE of bug 57268
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-25 11:17 EST by barnett2
Modified: 2016-11-24 09:55 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-25 11:17:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description barnett2 2002-02-25 11:17:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Windows NT 5.0; U)

Description of problem:
Line #37 of /usr/include/inttypes.h header file reads:
#  defined __need_wchar_t

#defined is not a valid directive.

This should read:
#  define __need_wchar_t

I've submitted this to glibc as well, and it is identified as "libc/3004".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. I don't know
2.
3.
	

Actual Results:  We're using the Intel Compiler, but that seems irrelevant as the line "#  defined" also won't work with the gcc compiler, either.

Additional info:

This error is causing our code not to build.  I don't know why our code is in this section, but that is irrelevant.  As far as how to reproduce the issue, 
I 
don't know, sorry.  I'm about 10 layers removed from the author of the code......
Comment 1 Jakub Jelinek 2002-02-25 11:29:11 EST
This actually worked with gcc, since it the code in question is #if'ed out
for gcc. Anyway, has been fixed for quite some time in errata.

*** This bug has been marked as a duplicate of 57268 ***
Comment 2 barnett2 2002-02-25 12:48:40 EST
Please advise which errata fixes this.

We have glibc-devel-2.2.4-19.3 installed [which is the last one available from updates.redhat.com], and the issue remains.
Comment 3 Jakub Jelinek 2002-02-26 05:46:14 EST
glibc-devel-2.2.4-19.3.
/usr/include/inttypes.h in that package has:
/* Get a definition for wchar_t.  But we must not define wchar_t itself.  */
#ifndef ____gwchar_t_defined
# ifdef __cplusplus
#  define __gwchar_t wchar_t
# elif defined __WCHAR_TYPE__
typedef __WCHAR_TYPE__ __gwchar_t;
# else
#  define __need_wchar_t
#  include <stddef.h>
typedef wchar_t __gwchar_t;
# endif
# define ____gwchar_t_defined   1
#endif

You must be using a different package if you don't see this in it.

Note You need to log in before you can comment on or make changes to this bug.