Bug 603279 - Install Script Sequence illogical
Summary: Install Script Sequence illogical
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-12 07:02 UTC by Wayne Carruthers
Modified: 2010-06-12 14:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-12 14:13:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wayne Carruthers 2010-06-12 07:02:20 UTC
Description of problem:

Script Sequence illogical

Version-Release number of selected component (if applicable):


How reproducible:

always


Steps to Reproduce:
1.
2.
3.
  
Actual results:

Anaconda requests select disks then goes off wanting machine name, root password then time zone before going to the next stage of disk formatting etc

This is illogical and wastes time waiting for CD/DVD

The above 3 items should be prior to going into disk type & formatting

Expected results:


Additional info:

Comment 1 Chris Lumens 2010-06-12 14:13:00 UTC
The first bit of disk selection is required to be early because we need to know which disks to consider when looking for upgradeable installations.  Then, we try to put as much stuff as possible before applying partitioning so there's fewer things to cause bugs before we modify hard drives.  The order of major items in anaconda is really pretty much forced to be the way it is now.


Note You need to log in before you can comment on or make changes to this bug.