Bug 60328 - Shell autocompletion on NFTS filesystem hangs kernel
Summary: Shell autocompletion on NFTS filesystem hangs kernel
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.2
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-25 18:08 UTC by Tommy Reynolds
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-25 18:08:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tommy Reynolds 2002-02-25 18:08:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.17-local i686)

Description of problem:
Linux 2.4.9.21 kernel configured for EXT3 filesystem with a read-only NTFS
filesystem mounted on "/dos/d".  Using ZSH's autocompletion command (ls
/dos/d/<TAB>) hangs the entire kernel, forcing a CPU reset to reboot.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Use EXT3 linux partitions
2. Mount an NTFS partition
3. Use ZSH shell autocompletion to list files in a directory: "ls /dos/d/<TAB>"
	

Actual Results:  System deadlock

Additional info:

Public 2.4.17 works correctly.  Check with SCT for a patch to correct locking
problem that causes this.

Comment 1 Arjan van de Ven 2002-02-25 18:11:27 UTC
Step 2 fails since we don't have ntfs enabled, because it's broken .....


Note You need to log in before you can comment on or make changes to this bug.