Bug 603294 - [abrt] crash in ModemManager-0.3-12.git20100504.fc13: raise: Process /usr/sbin/modem-manager was killed by signal 6 (SIGABRT)
[abrt] crash in ModemManager-0.3-12.git20100504.fc13: raise: Process /usr/sbi...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ModemManager (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
abrt_hash:b3a51fe5b1859441d391b71759b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-12 04:27 EDT by Stephan Ebelt
Modified: 2010-07-28 14:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-28 14:24:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (8.33 KB, text/plain)
2010-06-12 04:28 EDT, Stephan Ebelt
no flags Details
modem-manager --debug output (7.20 KB, text/plain)
2010-06-12 04:37 EDT, Stephan Ebelt
no flags Details

  None (edit)
Description Stephan Ebelt 2010-06-12 04:27:57 EDT
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/sbin/modem-manager
comment:  I suspect that modem-manager has a problem with asking for that PIN. I can make it work by manually entering the PIN with minicom (at-cpin="1111") and restarting modem-manager thereafter.
component: ModemManager
crash_function: raise
executable: /usr/sbin/modem-manager
global_uuid: b3a51fe5b1859441d391b71759bee528a32c7a32
kernel: 2.6.33.5-112.fc13.i686.PAE
package: ModemManager-0.3-12.git20100504.fc13
rating: 4
reason: Process /usr/sbin/modem-manager was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1.boot the system
2.watch /var/log/messages
3.modem-manager disappears and is constantly restarted by (presumably) NetworkManager
4.system has a Sierra UMTS Modem build in which needs a SIM PIN to activate it
Comment 1 Stephan Ebelt 2010-06-12 04:28:00 EDT
Created attachment 423460 [details]
File: backtrace
Comment 2 Stephan Ebelt 2010-06-12 04:37:38 EDT
Created attachment 423461 [details]
modem-manager --debug output

this is the modem-manager --debug output which (most likely) produced this backtrace. I ran it with the Sierra Modem being inactive, ie has no PIN.  After manually entering the PIN it worked.

there was additional output from /var/log/messages posted in bug #597088.
Comment 3 Dan Williams 2010-06-24 12:20:05 EDT
Should be fixed upstream be:

commit adfe264b67ba28effd3fb8378cbcbe2081f6ed49
Author: Dan Williams <dcbw@redhat.com>
Date:   Tue Jun 22 01:58:54 2010 -0700

    core: ensure claimed ports don't fall back to Generic (rh #597296)

This isn't a dupe of that bug though since that commit doesn't fix rh #597296, but should fix this bug.
Comment 4 Stephan Ebelt 2010-07-28 14:24:16 EDT
I upgraded ModemManager from updates-testing as was mentioned in bug #597088 to ModemManager-0.4-4.git20100720.fc13.i686. This appears to solve this bug.

I can now boot my system and it comes up with asking for the PIN right after login and the UMTS connection is available in nm-applet.

thanks,
stephan

Note You need to log in before you can comment on or make changes to this bug.