Bug 603321 - Scanner Mustek 2448TA Pro doesn't work
Summary: Scanner Mustek 2448TA Pro doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sane-backends
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-12 11:53 UTC by Alexei Panov
Modified: 2010-12-03 20:45 UTC (History)
4 users (show)

Fixed In Version: sane-backends-1.0.21-5.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-03 20:44:55 UTC
Type: ---


Attachments (Terms of Use)
patch for fix bug (369 bytes, patch)
2010-11-22 11:42 UTC, Alexei Panov
no flags Details | Diff

Description Alexei Panov 2010-06-12 11:53:58 UTC
Description of problem:
Package version 1.0.21-1/1.0.21-2 does not contain library libsane-mustek_usb2.so and associated files.

Version-Release number of selected component (if applicable):
1.0.21-1/1.0.21-2

How reproducible:
Compare the contents of packages sane versions 1.0.20 and 1.0.21.
As example: 
http://koji.fedoraproject.org/koji/rpminfo?rpmID=1744988 (1.0.20-11, files present)
http://koji.fedoraproject.org/koji/rpminfo?rpmID=1959121 (1.0.21-1, files are missing)

Actual results:
After update not working scanner Mustek 2448TA Pro

Expected results:
Availability required for scanner files (as in version 1.0.20)

Additiona information:
Temporary workaround: downgrade to sane-backends-1.0.20-11

Comment 1 Eugene Saenko 2010-06-12 17:02:27 UTC
Confirm this bug.

Comment 2 Mark P. 2010-07-19 11:44:24 UTC
Also confirm this bug.

Comment 3 Eugene Saenko 2010-11-20 22:32:34 UTC
This bug exists in Fedora 14 too.

Comment 4 Alexei Panov 2010-11-22 11:42:44 UTC
Created attachment 461981 [details]
patch for fix bug

Also I build packages with this patch.
Packages here http://elemc.fedorapeople.org/fixed-sane-backends/
Please check packages.

Comment 5 Eugene Saenko 2010-11-22 11:55:27 UTC
I have tested binary packages from: 
http://elemc.fedorapeople.org/fixed-sane-backends/
on 32-bit Fedora 14.

All works for me fine.

Comment 6 Nils Philippsen 2010-11-23 10:55:06 UTC
I've looked at this more closely yesterday and I can only guess that (for whatever reason) the older sane-backends versions were built against libpthread even though I didn't specify --enable-pthread in the spec file.

I've kicked off builds with this enabled.

Comment 7 Fedora Update System 2010-11-23 11:27:47 UTC
sane-backends-1.0.21-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/sane-backends-1.0.21-5.fc14

Comment 8 Fedora Update System 2010-11-23 11:28:40 UTC
sane-backends-1.0.21-5.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/sane-backends-1.0.21-5.fc13

Comment 9 Fedora Update System 2010-11-23 21:59:24 UTC
sane-backends-1.0.21-5.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sane-backends'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/sane-backends-1.0.21-5.fc14

Comment 10 Eugene Saenko 2010-11-25 07:35:59 UTC
I've tested this testing update on 32-bit Fedora 14. Works fine for me.
Thank you :)

Comment 11 Alexei Panov 2010-11-25 09:04:51 UTC
It's works for me and libsane-mustek_usb2.so presented in package
http://koji.fedoraproject.org/koji/rpminfo?fileStart=150&rpmID=2267958&fileOrder=name&buildrootOrder=-id&buildrootStart=0#filelist

Thanks.

Comment 12 Nils Philippsen 2010-11-25 13:52:51 UTC
If any of you have Fedora accounts, please add "karma" comments to the update page. Thanks!

Comment 13 Fedora Update System 2010-12-03 20:44:51 UTC
sane-backends-1.0.21-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2010-12-03 20:45:37 UTC
sane-backends-1.0.21-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.