Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 603339 - ATI Radeon HD 2400 blank screen after gdm login without nomodeset
ATI Radeon HD 2400 blank screen after gdm login without nomodeset
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-12 09:14 EDT by Doug Kelly
Modified: 2018-04-11 04:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-13 17:06:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (29.01 KB, text/plain)
2010-06-12 09:14 EDT, Doug Kelly
no flags Details
xorg.conf (1.40 KB, text/plain)
2010-06-12 09:14 EDT, Doug Kelly
no flags Details
Xorg.1.log (4.61 KB, text/plain)
2010-06-12 09:15 EDT, Doug Kelly
no flags Details

  None (edit)
Description Doug Kelly 2010-06-12 09:14:03 EDT
Created attachment 423496 [details]
Xorg.0.log

Description of problem:
With the fglrx driver (vendor-supplied) and nomodeset not enabled, the login screen appears, but after login the screen goes blank and monitors go into powersave mode.  Hard shutdown needed to reboot.
Setting the nomodeset parameter allows it work as expected (goes to a user desktop)
Logging a bug here as requested by the "common f12 bugs" page on fedoraproject.org.

Version-Release number of selected component (if applicable):
Catalyst 10.5

How reproducible:
Easily repeatable

Steps to Reproduce:
1. Boot without the nomodeset kernel parameter
2. Login
3. Blank screen
  
Actual results:
Blank screen

Expected results:
Progression to user desktop (gnome)

Additional info:
This was an upgrade from F11 to F12 using preupgrade.  Older xorg.log files say they can't find an fglrx driver, but that's likely because one for F12 wasn't installed until after the 2nd or 3rd or 4th reboot.  (I had other issues as well relating to AIGLX and Xinerama that worked under F11 but not F12)  I needed to remove the xorg.conf file altogether to get to a desktop at all so I could get the newest driver (it worked, but was slow--nomodeset /may/ have been needed as well there--will try to recreate and update the bug).
Comment 1 Doug Kelly 2010-06-12 09:14:28 EDT
Created attachment 423498 [details]
xorg.conf
Comment 2 Doug Kelly 2010-06-12 09:15:04 EDT
Created attachment 423499 [details]
Xorg.1.log
Comment 3 Matěj Cepl 2010-06-13 17:06:53 EDT
Thanks for the report. We are sorry that we cannot help you with your problem, but we are not able to support binary-only drivers. If you would be able to reproduce this issue using only open source software, please, reopen this bug with the additional information, but in meantime I have no choice than to close this bug as CANTFIX (because we really cannot fix it).

Note You need to log in before you can comment on or make changes to this bug.