Bug 603344 - On install, Fedora selected all Linux swap partitions and entered them for mounting in fstab
On install, Fedora selected all Linux swap partitions and entered them for mo...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-12 09:54 EDT by Steve Scheider
Modified: 2012-09-26 17:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-16 10:12:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Scheider 2010-06-12 09:54:48 EDT
Description of problem:
The installer requires a bit of granularity with linux swap partitions.  It could be told which were available for this installations use or a feature could prevent a partition from being used by the installer.

Version-Release number of selected component (if applicable):
n/a.  Distro that I used was Fedora 13 with gnome.

How reproducible:
Very.  Create a drive with multiple linux swap partitions using gpartd and install Fedora.  The install will use them all as entries in fstab.

Steps to Reproduce:
1.  see above
2.
3.
  
Actual results:


Expected results:


Additional info:
This is more an annoyance, since you can trace it out using the UUIDs in fstab and a ls -al /dev/disk/by-UUID/*, then remove the undesired entries.  However, other os's do have a prevention mechanism in thier distros.
Comment 1 Chris Lumens 2010-06-16 10:12:11 EDT

*** This bug has been marked as a duplicate of bug 70477 ***
Comment 2 Fedora Update System 2012-08-14 14:36:49 EDT
munin-2.0.5-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/munin-2.0.5-1.fc17
Comment 3 Fedora Update System 2012-08-14 14:53:24 EDT
munin-2.0.5-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/munin-2.0.5-1.fc16
Comment 4 Fedora Update System 2012-08-14 14:59:59 EDT
munin-2.0.5-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/munin-2.0.5-1.el6
Comment 5 Fedora Update System 2012-08-19 21:52:06 EDT
munin-2.0.5-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/munin-2.0.5-2.fc17
Comment 6 Fedora Update System 2012-08-19 21:53:42 EDT
munin-2.0.5-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/munin-2.0.5-2.fc16
Comment 7 Fedora Update System 2012-08-20 00:12:18 EDT
munin-2.0.5-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/munin-2.0.5-3.el6
Comment 8 Fedora Update System 2012-09-01 09:01:29 EDT
munin-2.0.6-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/munin-2.0.6-1.fc17
Comment 9 Fedora Update System 2012-09-01 09:46:05 EDT
munin-2.0.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/munin-2.0.6-1.fc16
Comment 10 Fedora Update System 2012-09-01 15:41:27 EDT
munin-2.0.6-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/munin-2.0.6-1.el6
Comment 11 Fedora Update System 2012-09-08 02:40:08 EDT
munin-2.0.6-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/munin-2.0.6-2.fc17
Comment 12 Fedora Update System 2012-09-08 03:27:34 EDT
munin-2.0.6-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/munin-2.0.6-2.fc16
Comment 13 Fedora Update System 2012-09-08 03:41:03 EDT
munin-2.0.6-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/munin-2.0.6-2.el6
Comment 14 Fedora Update System 2012-09-26 05:00:27 EDT
munin-2.0.6-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2012-09-26 05:07:40 EDT
munin-2.0.6-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2012-09-26 17:37:14 EDT
munin-2.0.6-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.