Bug 603347 - [abrt] crash in Miro-3.0.2-1.fc13: widgetset.py:121:reload:TypeError: WebKitWebFrame.load_uri() argument 1 must be string, not None
Summary: [abrt] crash in Miro-3.0.2-1.fc13: widgetset.py:121:reload:TypeError: WebKitW...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Miro
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Michel Alexandre Salim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3c3db071
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-12 14:19 UTC by boucher.samuel.c
Modified: 2010-09-15 05:52 UTC (History)
6 users (show)

Fixed In Version: Miro-3.0.3-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-14 05:04:33 UTC


Attachments (Terms of Use)
File: backtrace (1.53 KB, text/plain)
2010-06-12 14:19 UTC, boucher.samuel.c
no flags Details

Description boucher.samuel.c 2010-06-12 14:19:52 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/miro.real
component: Miro
executable: /usr/bin/miro.real
kernel: 2.6.33.5-112.fc13.x86_64
package: Miro-3.0.2-1.fc13
reason: widgetset.py:121:reload:TypeError: WebKitWebFrame.load_uri() argument 1 must be string, not None
release: Fedora release 13 (Goddard)

backtrace
-----
widgetset.py:121:reload:TypeError: WebKitWebFrame.load_uri() argument 1 must be string, not None

Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/gtk/weakconnect.py", line 49, in handle_callback
    return real_method(obj, *(args + self.user_args))
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/gtk/base.py", line 206, in do_forward_signal
    self.emit(forwarded_signal_name, *args)
  File "/usr/lib64/python2.6/site-packages/miro/signals.py", line 155, in emit
    if callback.invoke(self, args):
  File "/usr/lib64/python2.6/site-packages/miro/signals.py", line 76, in invoke
    return self.func(obj, *(args + self.extra_args))
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/browser.py", line 123, in _on_reload_button_clicked
    self.emit('browser-reload')
  File "/usr/lib64/python2.6/site-packages/miro/signals.py", line 155, in emit
    if callback.invoke(self, args):
  File "/usr/lib64/python2.6/site-packages/miro/signals.py", line 89, in invoke
    return callback(obj, *(args + self.extra_args))
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/browser.py", line 243, in _on_browser_reload
    self.browser.reload()
  File "/usr/lib64/python2.6/site-packages/miro/plat/frontends/widgets/widgetset.py", line 121, in reload
    self._browser.get_frame().load_uri(self.url)
TypeError: WebKitWebFrame.load_uri() argument 1 must be string, not None

Local variables in innermost frame:
self: <miro.frontends.widgets.browser.Browser object at 0x324ecd0>

Comment 1 boucher.samuel.c 2010-06-12 14:19:55 UTC
Created attachment 423515 [details]
File: backtrace

Comment 2 Michel Alexandre Salim 2010-06-23 12:56:27 UTC
Thanks for the report. Could you provide the steps that need to be taken to reproduce this? Looks like in this case self.url is None (Python's NULL); it'd be nice to know where this None value comes from.

Comment 3 Walt 2010-08-18 02:25:37 UTC
Package: Miro-3.0.2-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Refresh Miro guide
2.
3.

Comment 4 Fedora Update System 2010-08-29 17:19:54 UTC
Miro-3.0.3-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc14

Comment 5 Fedora Update System 2010-08-29 17:26:59 UTC
Miro-3.0.3-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc13

Comment 6 Fedora Update System 2010-08-29 17:31:06 UTC
Miro-3.0.3-1.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc12

Comment 7 Fedora Update System 2010-08-30 19:41:45 UTC
Miro-3.0.3-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc14

Comment 8 will kahn-greene 2010-08-30 21:09:24 UTC
I'm not sure how to reproduce this or why self.url would be None there, but I added some defensive programming in 89a11bf.  That'll go out with Miro 3.5.

Comment 9 Mykal Anderson 2010-09-07 01:31:25 UTC
Package: Miro-3.0.2-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


Comment
-----
Browser reported could not resolve hostname. Miro appeared to still work as a player though.

Comment 10 Fedora Update System 2010-09-14 05:02:38 UTC
Miro-3.0.3-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2010-09-15 05:34:32 UTC
Miro-3.0.3-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2010-09-15 05:49:39 UTC
Miro-3.0.3-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.