Bug 603348 - [UMing] Only upper half characters are displayed.in java application
[UMing] Only upper half characters are displayed.in java application
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: man lung wong
Fedora Extras Quality Assurance
:
Depends On: 597096
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-12 10:20 EDT by Nicolas Mailhot
Modified: 2010-06-18 09:30 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 597096
Environment:
Last Closed: 2010-06-18 09:30:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2010-06-12 10:20:47 EDT
+++ This bug was initially created as a clone of Bug #597096 +++

Created an attachment (id=417485)
Freemind with UMing font

Description of problem:
When using uming font in java application, only upper half the characters are displayed.

Version-Release number of selected component (if applicable):
cjkuni-uming-fonts-0.2.20080216.1-37.fc13.noarch

How reproducible:
Always

Steps to Reproduce:
1. We use freemind for example.
2. Download freemind zip and install it, say, in /tmp/freemind
3. cd /tmp/freemind; chmod 755 freemind.sh; ./freemind.sh
4. In F-13, java is not able to show Chinese, because the font name and path changes. Suppose we use java-1.6.0-openjdk.
5. su or sudo as root
6. cd /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib
7. cp fontconfig.Fedora.properties.src fontconfig.Fedora.properties
8. Either manually search/replace AR PL ShanHeiSong to AR PL UMing HK fontconfig.Fedora.properties; or use attached fontconfig.Fedora.properties
9. Start freemind to see the how font is displayed
  
Actual results:
UMing characters are cut in to half. See Screenshot-uming.png

Expected results:
UMing characters are displayed as whole.

Additional info:
UKai seems act normally. See Screenshot-ukai.png

--- Additional comment from dchen@redhat.com on 2010-05-28 02:07:16 EDT ---

Created an attachment (id=417487)
Freemind with UKai font

--- Additional comment from dchen@redhat.com on 2010-05-28 02:08:29 EDT ---

Created an attachment (id=417488)
Fontconfig file for java
Comment 1 man lung wong 2010-06-15 15:34:20 EDT
How did you get the Chinese text to show up on freemind instead of English? 

I downloaded and installed freemind 0.8.1 from http://freemind.sourceforge.net/wiki/index.php/Download

I downloaded the full binary file.

Thanks,
Man Lung Wong
Comment 2 man lung wong 2010-06-15 15:46:07 EDT
Also what did you set as the system language?

Thanks,
Man Lung Wong
Comment 3 Ding-Yi Chen 2010-06-17 01:29:58 EDT
In bash/zsh

export LANG=zh_TW.utf8

In tcsh

setenv LANG zh_TW.utf8
Comment 4 man lung wong 2010-06-17 10:20:16 EDT
Hmm.... the Chinese characters seem to be showing up as boxes. Would you by any chance know the reason behind that?

FWIW, I also tested on my f11 system, the problem doesn't exist there.

Thanks,
Man Lung Wong
Comment 5 man lung wong 2010-06-17 10:25:50 EDT
By the problem I mean, the Chinese characters show up in Uming and do not get cut in half.

Man Lung Wong
Comment 6 Ding-Yi Chen 2010-06-17 19:26:16 EDT
Mmm, I tested it today with F-13 and F-12, seems like this problem have been somehow fixed. 

I've checked /var/log/yum.log, maybe it's one of the java-1.6.0-openjdk update that eliminate this bug, though I am not certain.

You may close this bug now.

Note You need to log in before you can comment on or make changes to this bug.