Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 603365 - Perl module Apache2::Request fails to load
Perl module Apache2::Request fails to load
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libapreq2 (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Bojan Smojver
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-12 12:06 EDT by Zbigniew Fiedorowicz
Modified: 2010-07-06 13:12 EDT (History)
2 users (show)

See Also:
Fixed In Version: libapreq2-2.12-6.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-06 13:12:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zbigniew Fiedorowicz 2010-06-12 12:06:54 EDT
Description of problem:


Version-Release number of selected component (if applicable):
perl-libapreq2-2.12-3.fc13.i686

How reproducible:
Provided perl module does not load

Steps to Reproduce:
1. Execute the following script
#!/usr/bin/perl
use Apache2::Request;

2.
3.
  
Actual results:
Produces the following error message:

Can't load '/usr/lib/perl5/auto/APR/Request/Request.so' for module APR::Request: /usr/lib/perl5/auto/APR/Request/Request.so: undefined symbol: apreq_hook_disable_uploads at /usr/lib/perl5/DynaLoader.pm line 200.
 at /usr/lib/perl5/APR/Request/Param.pm line 27
Compilation failed in require at /usr/lib/perl5/APR/Request/Param.pm line 27.
BEGIN failed--compilation aborted at /usr/lib/perl5/APR/Request/Param.pm line 27.
Compilation failed in require at /usr/lib/perl5/Apache2/Request.pm line 2.
BEGIN failed--compilation aborted at /usr/lib/perl5/Apache2/Request.pm line 2.
Compilation failed in require at /tmp/test.pl line 2.
BEGIN failed--compilation aborted at /tmp/test.pl line 2.


Expected results:
Module should load properly

Additional info:
Comment 1 Zbigniew Fiedorowicz 2010-06-12 14:30:26 EDT
Replacing the Fedora 13 version of Request.so with the latest Fedora 12 version of the same file seems to fix the problem.
Comment 2 Mamoru TASAKA 2010-06-13 09:27:46 EDT
Debian seems to have a fix for this:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=573062
Comment 3 Bojan Smojver 2010-06-15 21:15:47 EDT
Looks like the fix introduced during F-13 development cycle didn't actually fix this:

http://cvs.fedoraproject.org/viewvc/rpms/libapreq2/devel/libapreq2-2.12-install.patch?revision=1.1&view=markup
Comment 4 Bojan Smojver 2010-06-22 02:25:34 EDT
Somehow mock builds this differently. When I build the same RPM on my box, it works. Digging...
Comment 5 Fedora Update System 2010-06-22 05:20:28 EDT
libapreq2-2.12-6.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libapreq2-2.12-6.fc13
Comment 6 Fedora Update System 2010-06-22 13:15:58 EDT
libapreq2-2.12-6.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libapreq2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libapreq2-2.12-6.fc13
Comment 7 Fedora Update System 2010-07-06 13:12:04 EDT
libapreq2-2.12-6.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.