Bug 603392 - Unchecking "Show list of users" option results in inability to log-in via the Gnome GUI
Unchecking "Show list of users" option results in inability to log-in via the...
Status: CLOSED DUPLICATE of bug 590456
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
13
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-12 16:08 EDT by Denny Crane
Modified: 2015-01-14 18:25 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-02 05:48:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denny Crane 2010-06-12 16:08:20 EDT
Description of problem:
This application offers a few configuration options, including "Show list of users," which is checked by default. Unchecking this option leads to the inability to log-in through the Gnome GUI.

Version-Release number of selected component (if applicable):
0.6-3

How reproducible:
I was not about to try it again after having to reinstall Fedora from scratch. If you need any assistance with testing, let me know and I'll do it in a virtual machine.

Steps to Reproduce:
1.Install fresh copy of Fedora 13 64-bit Gnome live media
2.Remove the following packages: smolt, smolt-firstboot, bluez, cheese, cheese-libs, pino, planner, evolution
3.Update all packages and reboot
4.Install accountsdialog package, including cheese-libs package which I had just previously removed
5.Run accountsdialog application and uncheck "Show list of users" option
6.Reboot
  
Actual results:
The log-in screen is unusable. The dialog which normally appears at the center of the screen has been reduced to 1-3 pixels in width and is blinking. It looks like a gigantic text cursor. Placing the mouse cursor over this changes the mouse cursor to the waiting mouse cursor. Attempting to input log-in credentials via keyboard and human memory had no observable effect. The panel which normally appears at the bottom of the screen is missing. Ctrl-Alt-F2, log-in as root, yum remove accountsdialog does not fix this. Messages about dbus appear while removing and while attempting to do other things from the command line (such as an attempt to install nano, which failed). Upon returning to the GUI, the panel at the bottom had reappeared, but the center dialog had not. Reboot. Same result.

Expected results:
List of users is replaced via input wherein the user must enter their log-in name.

Additional info:
Ask
Comment 1 Denny Crane 2010-06-14 23:05:33 EDT
It looks like this is most likely a Gnome issue, as I tried setting the default for the /apps/gdm/simple-greeter/disable_user_list key in gconf-editor to true, and that had the same effect.

In case anyone else gets stuck in this situation, the way I corrected the problem (undid the change) was by editing /etc/inittab such that initdefault is 3, then reboot, log-in, startx, disable the setting, and edit /etc/inittab again such that the initdefault is 5.
Comment 2 Edgar Hoch 2010-07-17 09:38:07 EDT
This seems to be a duplicate of bug 590456.
Comment 3 Matthias Clasen 2010-07-21 21:11:52 EDT
Not a problem of the accounts dialog, which just changes the gdm configuration.
Moving to gdm
Comment 4 Tajidin Abdullah 2010-08-02 05:48:28 EDT
This bug has been triaged



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 590456 ***

Note You need to log in before you can comment on or make changes to this bug.