Bug 603396 - [abrt] report-0.14-1.fc14: __init__.py:229:open_signature_file:UnboundLocalError: local variable 'xml_file' referenced before assignment
Summary: [abrt] report-0.14-1.fc14: __init__.py:229:open_signature_file:UnboundLocalEr...
Status: CLOSED DUPLICATE of bug 594890
Alias: None
Product: Fedora
Classification: Fedora
Component: report   
(Show other bugs)
Version: 14
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gavin Romig-Koch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ea3fe2b8
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-12 20:27 UTC by Andrew Hecox
Modified: 2010-08-13 13:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-13 13:37:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (752 bytes, text/plain)
2010-06-12 20:27 UTC, Andrew Hecox
no flags Details

Description Andrew Hecox 2010-06-12 20:27:21 UTC
abrt version: 1.1.5
architecture: i686
cmdline: /usr/bin/python /usr/bin/report --gtk pkgconfig
comment: sending an empty file is weird, but report shouldn't blow up
component: report
executable: /usr/bin/report
kernel: 2.6.34-20.fc14.i686.PAE
package: report-0.14-1.fc14
reason: __init__.py:229:open_signature_file:UnboundLocalError: local variable 'xml_file' referenced before assignment
release: Fedora release 14 (Rawhide)
time: 1276374132
uid: 12567

backtrace
-----
__init__.py:229:open_signature_file:UnboundLocalError: local variable 'xml_file' referenced before assignment

Traceback (most recent call last):
  File "/usr/bin/report", line 118, in <module>
    if report.isSignatureFile(opts.filename):
  File "/usr/lib/python2.6/site-packages/report/__init__.py", line 263, in isSignatureFile
    file_pair = open_signature_file( filename, None, skipErrorMessage = True )
  File "/usr/lib/python2.6/site-packages/report/__init__.py", line 229, in open_signature_file
    if not xml_file:
UnboundLocalError: local variable 'xml_file' referenced before assignment

Local variables in innermost frame:
tar_file: <tarfile.TarFile object at 0x9e40b0c>
skipErrorMessage: True
io: None
filename: '/home/ahecox/pkgconfig'

How to reproduce
-----
1. report <empty-file>
2. BOOM!

Comment 1 Andrew Hecox 2010-06-12 20:27:23 UTC
Created attachment 423550 [details]
File: backtrace

Comment 2 Bug Zapper 2010-07-30 12:06:55 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Gavin Romig-Koch 2010-08-13 13:37:20 UTC

*** This bug has been marked as a duplicate of bug 594890 ***


Note You need to log in before you can comment on or make changes to this bug.