Bug 603418 - Exception: device-mapper: reload ioctl failed: Invalid argument
Exception: device-mapper: reload ioctl failed: Invalid argument
Status: CLOSED DUPLICATE of bug 533703
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
anaconda_trace_hash:5b027476e74516340...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-12 23:30 EDT by Brock
Modified: 2010-07-01 03:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-01 03:57:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (104.74 KB, text/plain)
2010-06-12 23:30 EDT, Brock
no flags Details

  None (edit)
Description Brock 2010-06-12 23:30:06 EDT
The following was filed automatically by anaconda:
anaconda 13.42 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/block/__init__.py", line 33, in dm_log
    raise Exception, message
  File "/usr/lib64/python2.6/site-packages/block/device.py", line 706, in get_map
    self._RaidSet__map = _dm.map(name=self.name, table=self.rs.dmTable)
  File "/usr/lib64/python2.6/site-packages/block/device.py", line 823, in activate
    self.map.dev.mknod(self.prefix+self.name)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1688, in handleUdevDMRaidMemberFormat
    rs.activate(mknod=True)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1814, in handleUdevDeviceFormat
    self.handleUdevDMRaidMemberFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1310, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1968, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 380, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 103, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1313, in nextClicked
    self.anaconda.dispatch.gotoNext()
Exception: device-mapper: reload ioctl failed: Invalid argument
Comment 1 Brock 2010-06-12 23:30:10 EDT
Created attachment 423574 [details]
Attached traceback automatically from anaconda.
Comment 2 Brock 2010-06-12 23:39:54 EDT
During attempted install of Fedora Core 13. Reached the "select storage..." selections. I choose custom rather then basic as I am running a RAID 5 setup (HW BIOS) with 4-250gb drives. The RAID tab shows up and identified my storage device in the window. When I checked it for use and clicked next, the exception error above/that I filed is where it dumps on me.  -Thanks
Comment 3 Hans de Goede 2010-07-01 03:57:51 EDT
Brock,

You are using Firmware RAID level 5 on something other then an Intel chipset,
for anything but Intel Firmware RAID we use dmraid (as mdraid only supports Intel Firmware RAID). And device mapper raid (dmraid) does not support RAID level 5. This works with RHEL-5.5 / CentOS because the 5.5 kernel devicemapper code is patched to handle RAID 4/5, the Fedora kernels do not have this patch and thus when anaconda tries to setup the RAID array it fails with the following error:
23:07:57,102 ERR kernel:device-mapper: table: 253:0: raid45: unknown target type

We already have a bug for tracking this issue, esp, see:
https://bugzilla.redhat.com/show_bug.cgi?id=533703#c17

*** This bug has been marked as a duplicate of bug 533703 ***

Note You need to log in before you can comment on or make changes to this bug.