Bug 603420 - network driver does not implement netlogging yet
Summary: network driver does not implement netlogging yet
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: virtio   
(Show other bugs)
Version: 3.9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Rezanina
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-13 04:07 UTC by Qian Cai
Modified: 2013-01-09 22:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
This update adds support for a netlogging feature for virtio NIC.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-01 07:35:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add support for netlogging (1.19 KB, patch)
2010-06-28 13:44 UTC, Miroslav Rezanina
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2010:0813 normal SHIPPED_LIVE Virtio drivers for kernel 2.4.21-65.EL 2010-11-30 16:04:30 UTC

Description Qian Cai 2010-06-13 04:07:20 UTC
Description of problem:
Starting netdump daemon on RHEL3.9 guest with virtio NIC under RHEL6 host, giving errors,

# service  netdump restart
initializing netdump netlog: eth0's network driver does not implement netlogging yet, aborting.
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.21-63.ELsmp/kernel/drivers/net/netconsole.o: init_module: Operation not permitted
/lib/modules/2.4.21-63.ELsmp/kernel/drivers/net/netconsole.o: insmod /lib/modules/2.4.21-63.ELsmp/kernel/drivers/net/netconsole.o failed
/lib/modules/2.4.21-63.ELsmp/kernel/drivers/net/netconsole.o: insmod netconsole failed
[FAILED]

Version-Release number of selected component (if applicable):
GUEST:
2.4.21-63.ELsmp
kmod-virtio-smp-0.1-17.el3

HOST:
qemu-kvm-0.12.1.2-2.71.el6.x86_64
kernel-2.6.32-33.el6.x86_64
libvirt-0.8.1-7.el6.x86_64

How reproducible:
always

Comment 1 Miroslav Rezanina 2010-06-22 06:50:37 UTC
Hi CAI,
how do you configure server for netdump service?

Comment 2 Qian Cai 2010-06-22 07:05:38 UTC
Install netdump-server and use the default setup.

Comment 3 Miroslav Rezanina 2010-06-28 13:44:06 UTC
Created attachment 427422 [details]
Add support for netlogging

This patch set netlogging functionality to be built in.

Comment 4 Martin Prpič 2010-10-13 13:05:45 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
This update adds support for a netlogging feature for virtio NIC.

Comment 8 errata-xmlrpc 2010-11-01 07:35:56 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2010-0813.html


Note You need to log in before you can comment on or make changes to this bug.