Bug 60345 - RFE: Python packaging of py, pyc and pyo
Summary: RFE: Python packaging of py, pyc and pyo
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: python2 (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-26 11:27 UTC by Pedro Miguel Marques Morais
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-26 11:27:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pedro Miguel Marques Morais 2002-02-26 11:27:15 UTC
Description of Problem:
In most situations the py file from the class lib aren't needed,
since the pyc/pyo are preferred when importing it.

It would be nice to include ONLY the pyc/pyo in the base python package
and add an adicional python-py package that included the .py files;
even further maybe the pyc/pyo files could be in separetad rpms.

Version-Release number of selected component (if applicable):
All version, filled against python2 because it's a major change

Comment 1 Trond Eivind Glomsrxd 2002-02-26 14:56:01 UTC
Won't do that. I'd rather drop the pyc files. We don't need huge amounts of new
pseudo packages.

Comment 2 Pedro Miguel Marques Morais 2002-02-26 15:08:16 UTC
emacs has emacs-el; what use are the 1.676 MB (in python 1.5.2, not checked
for 2.2 but I'm sure it's a bigger number) of python source code forthe 
regular user?
We are talking about an almost 20% reduction in an almost mandatory package,
with no functional loss.
Anyway, since when is a large number of packages a bad thing?
The Redhat Perl packages are moving in that direction...



Comment 3 Nils Philippsen 2002-03-02 13:13:56 UTC
I regularily use the .py files as reference/interface documentation.


Note You need to log in before you can comment on or make changes to this bug.