Bug 603450 - SELinux is preventing /sbin/consoletype "read" access on /var/run/pm-utils/network/dhclient.suspend.
SELinux is preventing /sbin/consoletype "read" access on /var/run/pm-uti...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:075ee7147fd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-13 05:02 EDT by Viktor Erdelyi
Modified: 2010-07-06 13:08 EDT (History)
2 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-33.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-06 13:08:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Viktor Erdelyi 2010-06-13 05:02:38 EDT
Summary:

SELinux is preventing /sbin/consoletype "read" access on
/var/run/pm-utils/network/dhclient.suspend.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by consoletype. It is not expected that this
access is required by consoletype and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:consoletype_t:s0
Target Context                system_u:object_r:hald_var_run_t:s0
Target Objects                /var/run/pm-utils/network/dhclient.suspend [ file
                              ]
Source                        consoletype
Source Path                   /sbin/consoletype
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           initscripts-9.12-1.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-23.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.5-112.fc13.i686
                              #1 SMP Thu May 27 03:11:56 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Sun 13 Jun 2010 08:20:15 AM CEST
Last Seen                     Sun 13 Jun 2010 08:20:15 AM CEST
Local ID                      b63ddc7a-60ea-404e-b28f-d1215d907447
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1276410015.409:341): avc:  denied  { read } for  pid=29741 comm="consoletype" path="/var/run/pm-utils/network/dhclient.suspend" dev=dm-1 ino=531764 scontext=system_u:system_r:consoletype_t:s0 tcontext=system_u:object_r:hald_var_run_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1276410015.409:341): arch=40000003 syscall=11 success=yes exit=0 a0=95bcb68 a1=95b3450 a2=95b9f70 a3=95b3450 items=0 ppid=29740 pid=29741 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="consoletype" exe="/sbin/consoletype" subj=system_u:system_r:consoletype_t:s0 key=(null)



Hash String generated from  catchall,consoletype,consoletype_t,hald_var_run_t,file,read
audit2allow suggests:

#============= consoletype_t ==============
allow consoletype_t hald_var_run_t:file read;
Comment 1 Viktor Erdelyi 2010-06-13 05:03:10 EDT
Switched to permissive mode while waiting for 3.7.19-26 to fix the bash signal issue. It got beyond the bash signal in permissive mode and gave this one. (when using the hibernate feature)
Comment 2 Viktor Erdelyi 2010-06-13 05:06:35 EDT
I won't spam the bugzilla with two another bugs so here are two more AVC denials regarding consoletype:

Summary:

SELinux is preventing /sbin/consoletype "getattr" access on
/var/run/pm-utils/network/dhclient.suspend.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by consoletype. It is not expected that this
access is required by consoletype and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:consoletype_t:s0
Target Context                system_u:object_r:hald_var_run_t:s0
Target Objects                /var/run/pm-utils/network/dhclient.suspend [ file
                              ]
Source                        consoletype
Source Path                   /sbin/consoletype
Port                          <Unknown>
Host                          sierravista.nyetwork
Source RPM Packages           initscripts-9.12-1.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-23.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     sierravista.nyetwork
Platform                      Linux sierravista.nyetwork 2.6.33.5-112.fc13.i686
                              #1 SMP Thu May 27 03:11:56 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Sun 13 Jun 2010 08:20:15 AM CEST
Last Seen                     Sun 13 Jun 2010 08:20:15 AM CEST
Local ID                      ed0e986d-958b-4351-9246-5d1ef83d17f5
Line Numbers                  

Raw Audit Messages            

node=sierravista.nyetwork type=AVC msg=audit(1276410015.411:342): avc:  denied  { getattr } for  pid=29741 comm="consoletype" path="/var/run/pm-utils/network/dhclient.suspend" dev=dm-1 ino=531764 scontext=system_u:system_r:consoletype_t:s0 tcontext=system_u:object_r:hald_var_run_t:s0 tclass=file

node=sierravista.nyetwork type=SYSCALL msg=audit(1276410015.411:342): arch=40000003 syscall=197 success=yes exit=0 a0=0 a1=bfc47d2c a2=d42ff4 a3=3 items=0 ppid=29740 pid=29741 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="consoletype" exe="/sbin/consoletype" subj=system_u:system_r:consoletype_t:s0 key=(null)

----------------------------------------------------------------------



Summary:

SELinux is preventing /sbin/consoletype "ioctl" access on
/var/run/pm-utils/network/dhclient.suspend.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by consoletype. It is not expected that this
access is required by consoletype and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:consoletype_t:s0
Target Context                system_u:object_r:hald_var_run_t:s0
Target Objects                /var/run/pm-utils/network/dhclient.suspend [ file
                              ]
Source                        consoletype
Source Path                   /sbin/consoletype
Port                          <Unknown>
Host                          sierravista.nyetwork
Source RPM Packages           initscripts-9.12-1.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-23.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     sierravista.nyetwork
Platform                      Linux sierravista.nyetwork 2.6.33.5-112.fc13.i686
                              #1 SMP Thu May 27 03:11:56 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Sun 13 Jun 2010 08:20:15 AM CEST
Last Seen                     Sun 13 Jun 2010 08:20:15 AM CEST
Local ID                      49692af8-f693-4d04-a975-897dff0cb772
Line Numbers                  

Raw Audit Messages            

node=sierravista.nyetwork type=AVC msg=audit(1276410015.411:343): avc:  denied  { ioctl } for  pid=29741 comm="consoletype" path="/var/run/pm-utils/network/dhclient.suspend" dev=dm-1 ino=531764 scontext=system_u:system_r:consoletype_t:s0 tcontext=system_u:object_r:hald_var_run_t:s0 tclass=file

node=sierravista.nyetwork type=SYSCALL msg=audit(1276410015.411:343): arch=40000003 syscall=54 success=no exit=-25 a0=0 a1=541c a2=bfc47e1f a3=0 items=0 ppid=29740 pid=29741 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="consoletype" exe="/sbin/consoletype" subj=system_u:system_r:consoletype_t:s0 key=(null)
Comment 3 Daniel Walsh 2010-06-14 18:54:41 EDT
These are all caused by hal leaking file descriptors.  Hal is going a way so I guess we need to just dontaudit these.

	hal_dontaudit_read_pid_files(consoletype_t)
Comment 4 Miroslav Grepl 2010-06-15 01:04:08 EDT
Fixed in selinux-policy-3.7.19-29.fc13
Comment 5 Fedora Update System 2010-06-30 15:53:52 EDT
selinux-policy-3.7.19-33.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-33.fc13
Comment 6 Fedora Update System 2010-07-01 14:47:40 EDT
selinux-policy-3.7.19-33.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-33.fc13
Comment 7 Fedora Update System 2010-07-06 13:06:09 EDT
selinux-policy-3.7.19-33.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.