Bug 603459 - seabios cause "boot failure" when the guest is windows and disk type is virtio
seabios cause "boot failure" when the guest is windows and disk type is virtio
Status: CLOSED DUPLICATE of bug 596590
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: seabios (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-13 05:51 EDT by Jianjiao Sun
Modified: 2010-06-23 13:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-23 13:00:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianjiao Sun 2010-06-13 05:51:39 EDT
Description of problem:
When the guest is windows and disk type is virtio,The guest failed to boot,and the "blue screen" is seen.(I have test windows 2003 and windows 2008) 

Version-Release number of selected component (if applicable):
# rpm -q seabios
seabios-0.5.1-0.11.20100108git669c991.el6.x86_64
#rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.73.el6.x86_64
#rpm -qa |grep libvirt
libvirt-python-0.8.1-8.el6.x86_64
libvirt-qpid-0.2.20-2.el6.x86_64
libvirt-client-0.8.1-8.el6.x86_64
libvirt-devel-0.8.1-8.el6.x86_64
libvirt-0.8.1-8.el6.x86_64
# uname -a
Linux dhcp-65-144.nay.redhat.com 2.6.32-33.el6.x86_64 #1 SMP Thu Jun 3 13:00:03 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:
always

Steps to Reproduce:
1.define a guest with disk type is virtio (image is an exist image which support for virtio)
#virsh define win2008-2.xml
2.start the guest
#virsh start win2008-2
  
Actual results:
The guest failed to boot,and the "blue screen" is seen. 

Expected results:
Guest start successfully

Additional info:
After I downgrade the seabios to seabios-0.5.1-0.10.20100108git669c991.el6.x86_64 ,the guest start successfully.
If the guest disk's type is "ide",the guest also start successfully.

win2008-2.xml's content:
#cat win2008-2.xml
[root@dhcp-65-144 test]# cat win2008-2.xml 
<domain type='kvm' id='8'>
  <name>win2008-2</name>
  <uuid>edf73e0d-ded1-4762-96df-b6c4bbf68a3d</uuid>
  <memory>524288</memory>
  <currentMemory>524288</currentMemory>
  <vcpu>8</vcpu>
  <os>
    <type arch='x86_64' machine='rhel6.0.0'>hvm</type>
    <boot dev='hd'/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
  <clock offset='utc'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <devices>
    <emulator>/usr/libexec/qemu-kvm</emulator>
    <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2'/>
      <source file='/var/lib/libvirt/images/win2008-64-virtio.qcow2'/>
      <target dev='vdb' bus='virtio'/>
    </disk>
    <controller type='ide' index='0'>
      <alias name='ide0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
    </controller>
    <interface type='network'>
      <mac address='52:54:00:0c:c1:fe'/>
      <source network='default'/>
      <target dev='vnet1'/>
      <model type='virtio'/>
      <alias name='net0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
    </interface>
    <serial type='pty'>
      <source path='/dev/pts/2'/>
      <target port='0'/>
      <alias name='serial0'/>
    </serial>
    <console type='pty' tty='/dev/pts/2'>
      <source path='/dev/pts/2'/>
      <target port='0'/>
      <alias name='serial0'/>
    </console>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='5901' autoport='yes' keymap='en-us'/>
    <video>
      <model type='cirrus' vram='9216' heads='1'/>
      <alias name='video0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>
  </devices>
  <seclabel type='dynamic' model='selinux'>
    <label>system_u:system_r:svirt_t:s0:c279,c906</label>
    <imagelabel>system_u:object_r:svirt_image_t:s0:c279,c906</imagelabel>
  </seclabel>
</domain>
Comment 2 RHEL Product and Program Management 2010-06-13 06:03:14 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Eduardo Habkost 2010-06-22 11:52:13 EDT
Could you check if this is a duplicate of bug 596590?
Comment 4 Johnny Liu 2010-06-23 06:39:50 EDT
(In reply to comment #3)
> Could you check if this is a duplicate of bug 596590?    

Yes, look like it indeed is.
After I update viostor driver from http://download.lab.bos.redhat.com/devel/RHEV/virtio-win/1.1.5-0/virtio-win-1.1.5-0.vfd on the win2003 image, no blue screen is seen.
Comment 5 Eduardo Habkost 2010-06-23 13:00:48 EDT

*** This bug has been marked as a duplicate of bug 596590 ***

Note You need to log in before you can comment on or make changes to this bug.