Bug 603466 - Shouldn't antlr-tool obsolete antlr?
Shouldn't antlr-tool obsolete antlr?
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: antlr (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Milos Jakubicek
Fedora Extras Quality Assurance
:
: 627215 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-13 06:48 EDT by Bruno Wolff III
Modified: 2011-02-18 20:24 EST (History)
4 users (show)

See Also:
Fixed In Version: antlr-2.7.7-14.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-18 20:24:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2010-06-13 06:48:15 EDT
Description of problem:
When upgrading to rawhide I found the antlr package orphaned. It looks like antlr-tool replaces it now since antlr-tool provides antler. However since antrl-tool doesn't obsolete antler, it doesn't replace it on upgrade. I think you want to have antler-tool obsolete antler as well as provide it.

Version-Release number of selected component (if applicable):
antlr-tool-2.7.7-10.fc14.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Milos Jakubicek 2010-06-13 07:07:44 EDT
Definitely yes, sorry for inconvenience. I'll fix that soon.
Comment 2 Bug Zapper 2010-07-30 08:07:00 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Braden McDaniel 2010-11-04 12:20:18 EDT
This is actually an F13 problem because that's where the upgrade path has been broken. That is, persons upgrading from F13 with antlr installed won't get antlr-tool.
Comment 4 Felix Schwarz 2010-11-21 04:33:38 EST
(In reply to comment #1)
> Definitely yes, sorry for inconvenience. I'll fix that soon.

Any update on this? Because of the missing "Obsoletes", users need to resort to 'rpm -e --nodeps' to fix the situation. Adding this single line should be easy enough…
Comment 5 John Thacker 2011-01-15 10:59:27 EST
*** Bug 627215 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2011-02-07 05:31:05 EST
antlr-2.7.7-13.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/antlr-2.7.7-13.fc14
Comment 7 Fedora Update System 2011-02-07 07:55:34 EST
antlr-2.7.7-14.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/antlr-2.7.7-14.fc14
Comment 8 Fedora Update System 2011-02-07 07:55:44 EST
antlr-2.7.7-14.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/antlr-2.7.7-14.fc14
Comment 9 Fedora Update System 2011-02-07 14:55:41 EST
antlr-2.7.7-14.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update antlr'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/antlr-2.7.7-14.fc14
Comment 10 Fedora Update System 2011-02-18 20:24:17 EST
antlr-2.7.7-14.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.