Bug 60351 - GNU ld doesn't support incremental linking
GNU ld doesn't support incremental linking
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: binutils (Show other bugs)
8.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-26 09:38 EST by niv_twig
Modified: 2007-03-26 23:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 08:54:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description niv_twig 2002-02-26 09:38:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90; Hotbar 
3.0)

Description of problem:
Nowadays, linking and not compiler performance is the bottleneck in the
development and test cycle.
Incremental linking means that if you make a change in only 1 object file of
an executable,
the time to relink the executable will not be 10's of minutes for large
software projects but only a few seconds, since only changed data and
functions and references to them are updated in the executable. All the
other object files are not relinked again.

The gnu ld linker has no capability for incremental linking which is found
in almost all
other commercial linkers: Microsoft visual C++ linker, Sun ild (incremental
ld) linker for the Forte IDE, HP also has an incremental linker.

Here is a document with a description of how the HP-UX incremental
linker works.
It contains at the end references to other interesting docs about the
subject

http://www.usenix.org/events/osdi2000/wiess2000/full_papers/mikulin/mikulin.pdf
View this as HTML:
http://www.google.com/searchq=cache:xkjmZQf0O1YC:www.usenix.org/events/osdi2000/
wiess2000/full_papers/mikulin/mikulin.pdf+incremental+linking&hl=en


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.This is a request for enhancement and doesn't have steps to reproduce
2.
3.
	

Additional info:
Comment 1 niv_twig 2002-02-27 08:10:14 EST
I would also like to add that incremental linking is a very important 
INFRASTRUCTURE technology that will benefit and boost the development of ALL 
large open source projects since it reduces the development and test cycle 
times considerably. This is why I think this should be a high priority bug 
sponsored by the companies that support linux such as Redhat or IBM (although I 
doubt IBM will support that since they have a good technology of incremental 
compilation and linking in their VisualAge c++ product - much better than HP's 
technology I mentioned above. Search at their website for more details).
I don't think there is any other more important infrastracture technology that 
is missing in the GNU/Linux/Open source world than this.
Comment 2 Jakub Jelinek 2004-10-07 08:54:43 EDT
Please file enhancement request to upstream bug database instead,
though I don't see it much likely that anybody will work on it
in the near future.

Note You need to log in before you can comment on or make changes to this bug.