Bug 60361 - ifup add route when no route exists
Summary: ifup add route when no route exists
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.2
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-26 17:53 UTC by Andres Grino
Modified: 2014-03-17 02:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 19:40:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andres Grino 2002-02-26 17:53:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
ifup allways add a route for a non-aliases interface, even when the interface 
doesn't connect to a "proper" segment. Example: eth2 connect to a DMZ segment 
with machines having IP addresses taken from the segment connected to eth1 
interface (and you use proxy-arp to let machines from eth1 and eth2 segments 
think they are on the same wire).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Define eth1 with ip 10.1.1.1, netmask 255.255.255.0
2. Define eth2 with ip 10.1.1.2, netmask 255.255.255.255 (yes, because we 
really don't have a segment here)
3. service network restart
	

Actual Results:  Route to 0.0.0.0/0 is thru eth2 now.
Whoo!!! we just changed the default route.

Expected Results:  No route added at all.
We except that a netmask of 255.255.255.255 in ifcfg-ethN means "no network 
here".
We solved it changing line 236 in ifup script from:
   if [ "${ISALIAS}" = no ] ; then
to
   if [ "${ISALIAS}" = no -a "${PREFIX}" != "32"] ; then
because, after all, there is no point in adding/replacing a route when the 
netmask is 255.255.255.255.

Additional info:

While our net design may be a little non-ortodox, that scheme work in RedHat 
7.1 and earlier.

Comment 1 Bill Nottingham 2005-09-29 19:40:20 UTC
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.


Note You need to log in before you can comment on or make changes to this bug.