Bug 603610 - SELinux is preventing /usr/lib64/nspluginwrapper/npconfig "write" access on /usr/lib64/mozilla/plugins-wrapped/nswrapper_64_64.libgnashplugin.so.
Summary: SELinux is preventing /usr/lib64/nspluginwrapper/npconfig "write" access ...
Status: CLOSED DUPLICATE of bug 639808
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:7060dbd0f2f...
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-14 06:27 UTC by Amit Shah
Modified: 2010-10-04 08:57 UTC (History)
3 users (show)

Fixed In Version: selinux-policy-3.7.19-28.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-04 08:57:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Amit Shah 2010-06-14 06:27:12 UTC
Summary:

SELinux is preventing /usr/lib64/nspluginwrapper/npconfig "write" access on
/usr/lib64/mozilla/plugins-wrapped/nswrapper_64_64.libgnashplugin.so.

Detailed Description:

SELinux denied access requested by npconfig. It is not expected that this access
is required by npconfig and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:unconfined_r:sandbox_web_client_t:s0:
                              c229,c269
Target Context                unconfined_u:object_r:nsplugin_rw_t:s0
Target Objects                /usr/lib64/mozilla/plugins-
                              wrapped/nswrapper_64_64.libgnashplugin.so [ file ]
Source                        npconfig
Source Path                   /usr/lib64/nspluginwrapper/npconfig
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           nspluginwrapper-1.3.0-11.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-23.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.33.5-112.fc13.x86_64 #1 SMP Thu May 27
                              02:28:31 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Sun 13 Jun 2010 10:07:52 AM IST
Last Seen                     Sun 13 Jun 2010 10:07:52 AM IST
Local ID                      31931106-b1e6-4136-98f8-879630b69bb2
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1276403872.421:24169): avc:  denied  { write } for  pid=6718 comm="npconfig" name="nswrapper_64_64.libgnashplugin.so" dev=dm-3 ino=795533 scontext=unconfined_u:unconfined_r:sandbox_web_client_t:s0:c229,c269 tcontext=unconfined_u:object_r:nsplugin_rw_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1276403872.421:24169): arch=c000003e syscall=2 success=no exit=-13 a0=7fff9872ded0 a1=41 a2=1ed a3=1999999999999999 items=0 ppid=6705 pid=6718 auid=500 uid=500 gid=501 euid=0 suid=0 fsuid=0 egid=501 sgid=501 fsgid=501 tty=(none) ses=2 comm="npconfig" exe="/usr/lib64/nspluginwrapper/npconfig" subj=unconfined_u:unconfined_r:sandbox_web_client_t:s0:c229,c269 key=(null)



Hash String generated from  catchall,npconfig,sandbox_web_client_t,nsplugin_rw_t,file,write
audit2allow suggests:

#============= sandbox_web_client_t ==============
allow sandbox_web_client_t nsplugin_rw_t:file write;

Comment 1 Miroslav Grepl 2010-06-14 13:18:22 UTC
Fixed in selinux-policy-3.7.19-27.fc13

selinux-policy and selinux-policy-targeted packages are available from koji for now.

http://koji.fedoraproject.org/koji/buildinfo?buildID=177524

I will do a new update today.

Comment 2 Fedora Update System 2010-06-14 19:30:34 UTC
selinux-policy-3.7.19-28.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-28.fc13

Comment 3 Fedora Update System 2010-06-15 16:00:35 UTC
selinux-policy-3.7.19-28.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-28.fc13

Comment 4 Fedora Update System 2010-06-23 17:47:28 UTC
selinux-policy-3.7.19-28.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Amit Shah 2010-09-22 11:36:39 UTC
I'm still getting this with selinux-policy-3.7.19-57.fc13.noarch

Comment 6 Miroslav Grepl 2010-10-04 08:57:56 UTC

*** This bug has been marked as a duplicate of bug 639808 ***


Note You need to log in before you can comment on or make changes to this bug.