Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 603773 - hunspell treats dash as mis-spelled word
hunspell treats dash as mis-spelled word
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hunspell-en (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-14 10:42 EDT by Paul Howarth
Modified: 2010-06-14 11:15 EDT (History)
1 user (show)

See Also:
Fixed In Version: hunspell-en-0.20100322-4.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-14 11:03:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Howarth 2010-06-14 10:42:45 EDT
Description of problem:
hunspell in Rawhide treats a dash/hyphen character as a mis-spelled word.


Version-Release number of selected component (if applicable):
hunspell-1.2.11-1.fc14


How reproducible:
Every time


Steps to Reproduce:
mock-chroot> cat > fred
This is - a test.  
mock-chroot> cat > jim
This is - a yest.
mock-chroot> hunspell -l fred
mock-chroot> hunspell -l jim


Actual results:
mock-chroot> hunspell -l fred
-
mock-chroot> hunspell -l jim
-
yest.


Expected results (as per Fedora 13):
mock-chroot> hunspell -l fred
mock-chroot> hunspell -l jim
yest


Additional info:
The presence of the period at the end of "yest" in the Rawhide run suggests that the dash/hyphen may not be the only troublesome character.
Comment 1 Caolan McNamara 2010-06-14 10:58:23 EDT
specific to the english dictionaries
Comment 2 Caolan McNamara 2010-06-14 11:03:46 EDT
What I wanted to do was to allow "didn't" and other words with a non-typographical ' in them as a single word to be checked by the simple front-end. Looks like I got too loose. Fix up now I hope
Comment 3 Paul Howarth 2010-06-14 11:15:51 EDT
Works for me, thanks.

Note You need to log in before you can comment on or make changes to this bug.